Custom Resolution

Hello,

When creating layout if I select a custom resolution of 1920*359, the layout gets added to the middle portion of the region(highlighted in green) instead of starting from top(highlighted in red).

Did anyone faced this problem? Can someone please help me?

Hi Siddharth, welcome to the community!

When you create a custom resolution for your layouts, the canvas in the designer will adjust itself so that the entire layout resolution can be seen. It will also centre the layout canvas in the preview window. Because your layout is 1920x359, it is much wider than its height, so the layout resolution will appear narrow and elongated on the canvas. The black areas around the layout resolution shown in your screenshot (highlighted red) are not part of the layout, they are simply the background of the preview window.

You can also see the same if you create a 359x1920 resolution layout:

The grey vertical bar in the preview window is your entire layout, which has been centred on the preview window. The black areas either side are simply extra unused in the preview window.

Many Thanks.

Thanks for the explanation @DanBW.

However when we assign the layout to our actual physical sign it shows the red portion instead of green one. Is there any way we can show green portion on our physical sign ?

Thanks

Thank you for your reply. The red area in your screenshot is not part of the layout, so it is not possible that is showing on your player. The black area in the preview window is empty space outside of your layout. The grey area is the layout, 1920 wide by 359 high. You need to add all of your media items to that grey area for them to display on your player. Please also note that you may need to set the player window size to match this resolution, to ensure your layout fits correctly.

For example, lets say I create a 1920x359 layout:

All layouts have a single region that fits the full layout by default. I will keep this default region and add some text to it:

You can see that the text fills the grey area, as this is the layout area, not the black area.

If I connect a 1920x359 screen to my device running my player, I can set the player window dimensions to match the layout resolution:

Once the player has received those settings and been restarted to apply those changes, I can schedule that layout to the player and it will fit the full screen. Only the area in the layout designer that is grey will be rendered, anything outside of that grey area will not appear.

Many Thanks.

Thanks for the explanation @DanBW

Do you know where I can set the player window dimension in XIBO ?

Thanks

Thank you for your reply. To set the player window dimensions:

  • Go to the Displays menu in your CMS.
  • Click the button at the end of the entry for your player and choose Edit from the menu.
  • When the Edit Display window opens, go to the Profile Settings tab. This is where you will see the Screen Dimensions options.

Please note that the format for the options varies, depending on the player version you are using. For example, Android players will have this option:

Windows players have these options instead:

Both of the screenshots above show you how to set a resolution of 1920x359, starting from the top left corner of the screen.

As mentioned in my previous message, you need to set those options, then wait for the player to connect to your CMS (check the last accessed column to confirm when this has happened). Once you are sure the player has received those settings, close the player and restart it. You should now find the player window fits across your screen correctly.

Many Thanks.

Thanks for the update @DanBW. We will try to apply this solution with our test sign and will see how it goes. Hopefully it will resolve our query.

Thank you so much once again :slight_smile:

1 Like
The Xibo Community site uses cookies. What are cookies?