Custom Fonts Broken after upgrading to 1.7.7


I just upgraded from 1.7.4 to 1.7.7 and my custom fonts stopped working. They still display in the media list, but are not available in the editor and all layouts have reverted to the default browser font. Based on information from other posts, I have tried clearing the browser cache, opening each font file and saving it, reuploading font files, and changing the font file permissions. Still can’t get them to work. Any thoughts?


hmm so when you re upload them and do all the steps to ‘install’ them, they still don’t work?

I’d expect that edit->save, clear browser cache should do the trick.

Can you have a look for fonts.css in your library and tell us what’s in it please?

You can also send me one of your fonts that aren’t working and I’ll try it in our test environment.

Yeah, exactly. I’ve tried outright deleting the fonts and then reuploading them, etc but it doesn’t change anything. It’s worth noting that our Minix players are still displaying the correct custom fonts, it’s just the web interface that isn’t displaying them or making them available in the layout designer. I’ll send you one of the font files and also get information on the fonts.css file from our server team.

When you upload a font, it writes out a fonts.css file which is stored in your web server and player library. That font file isn’t replaced on upgrade (it used to be, but it isn’t now).

Editing any font would regenerate that file.

My guess would be that your web server has trouble writing to that file for some reason (a log would tell us).

Thanks for looking into that. This is what the log is showing:

Do you have instructions on what I should do to correct that?

Which web server / OS are you using?

It should be as simple as changing the ownership of that specific file to www-data