Custom Font not showing on Windows Player

The temp folder is now OK. File is correctly removed.

Unfortunately the font is not displayed on any Windows Client (Player). Should I create a new thread?

Anyway - thanks for your help.


I’ve moved it into a new topic for you.

Can you confirm that the fonts.css file is present and correct in the Windows Player local library folder, and that any referenced font files are also available in that folder?

Then can you find the temporary HTML file for the Layout/Widget you are looking at (they are named with the the format layoutid_regionid_widgetid) and open it in your browser on that PC.

Does the font display in that view? And if not are there any errors reported in the developer tools?

All files are in place and look correct.
I have found correct htm file with the content but it is named: 333.htm - this name doesn’t correspond to naming format ou have mentioned.
Anyway - I have opened it in 4 different browsers and only IE has a problem with fonts (it looks exactly the same as in Player). Chrome, FFox and Edge display the page (including fonts) correctly.
It looks that the Player use IE and that browser doesn’t display page properly.

Sorry - I forgot you are using 1.8, where the filename is widgetId.htm.

You are correct, the player does use IE.

Can you send me the 333.htm file, fonts.css and the actual font file so I can try it out?

Your font is failing in windows with this error:

@font-face failed OpenType embedding permission check. Permission must be Installable.

It may be that the font author has purposely disabled embedding this font - you could contact them to ask.

The CMS should detect this on upload and I will look at why it didn’t for this font.

1 Like

Thanks for the info.
I understand that there is no way to treat fonts the way other browser do?

I have checked Open Sans license and it should allow embedding but other people on the net had also such problems with this font.
I have downloaded a Open Sans in woff format from github and voila! Works perfectly!

Tomorrow I will do more testing and let you know.

1 Like

Correct - IE strictly obeys the licence information contained within the font.

Excellent - that is good news!

1 Like

Thank you thank you thank you. I’ve been having the same problem and it’s been driving me mad for days.
I was using Roboto, and using the woff file worked right away. :grin:

1 Like

I have done some testing and other Open Sans fonts in woff format work fine. Woff2 are not supported but I expected that.
For now woff solution seems to have solved the problem.
I have marked my previous post as a solution.
@dan During testing I have also noticed that files are still left in temp folder. It happens when file is not uploaded because of an error (i.e. format not supported or file format unreadable), also some (not all) files of debug package are left in temp. Perhaps the solution you have found has to be applied to other modules/files.

@Jo_1 Glad I could help :slight_smile:


1 Like

These will be tidied up by the maintenance routine, but I certainly take your point that it would be a good idea to clean up the file on error.

Excellent thanks very much.

Thank you for assistance and keep up the good work on Xibo.


1 Like