CMS V3.1.4 - Bug with the media upload form - Eternal Processing

CMS Version



Hi guys, I hope everyone is well.

We are finally using CMS 3.1.4 in several instances, and the reception has been great.

However, some bugs were naturally found with this version due to the amount of users using it.

The most impactful so far is in the media upload form, and the problem only occurs with the video upload.

It turns out that when any video file is uploaded, the form is never finished and remains “processing” forever. Additionally an error is generated in the console.

However, when the page is refreshed, we can see that the video was inserted into the timeline/library normally…

Can you reproduce this behavior out there?
Is there anything I can do here to solve this problem?

Thank you so much guys!!

Timeout message comming from: dist/core/file-upload.js
And thumbnail requested from: dist/core/xibo-cms.js



Apparently the problem is in the thumbnail generation.
I know it’s not the right thing to do, but I changed the return of the “saveVideoCoverImage(e)” function to true, in the file: dist/core/file-upload.js

And it works :open_mouth:

This way I can handle user complaints for a while
Thank’s again!

Hi @pitoco02, are you using a white label theme with your CMS? If so, I think you would need to rebuild it for v3 and then reapply it in order to resolve the problem.

Hi Frazer, Thanks for the answer!

I’m using a custom theme indeed. But it only changes colors and some images, nothing in the source code structure.

I switched to the original Xibo theme and it worked.

Can you tell me what configuration in the theme I should do? Thanks!

Perhaps this guide can help? Themes | Xibo Digital Signage
Please let me know if it does not.

Kind Regards,

oh yes… I made sure that the installation of my theme was following this documentation exactly.

What is strange to me is that in my theme (even in the views) there is no reference to upload forms, it shouldn’t affect anything, right?

If you’ve customised the views then at each new version you need to merge your changes in to the new version of the view file.

You can’t just keep the old version’s view file with your modifications in it.

So for each file in your theme, you need to get a fresh copy for version 3.1.4 and make whatever change you want in that fresh file.

Also it’s worth purging the content of the /cache folder too after each change as a precaution.

got it

I will review my views files, and validate if any are out of date

When it’s over, I’ll let you know if it worked.

Thank you again

Hi Frazer!
You were absolutely right in this case.
A file of my template was out of date for the version. In this case the bug was caused by myself.
I updated the version of all the view files of my custom template, and everything went well.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.