CMS refusing connections

Version 3.0.6
Using both Windows version 3 clients and WebOs clients.
A couple of weeks ago, all of my Displays just stopped updating.
(We did change some network hardware around that time, but not sure if that is related.)
I tried to add a new WebOs display, it let me authorize it, but it would not download the layout.
Then I realized the other displays were not updating either.
My windows client lost the connection settings. I put them back in and it says “Bad Request” when I try to reconnect.

I am able to get to the CMS via the web on port 8080 no problem, and the xml connection works on port 9505. So, I assume it is not a firewall issue. (Not using https) Nothing has changed in Docker as far as I know.

Tried deleting the Windows client display in the CMS. Deleting the local files in the user account, and reinstalling the newest V3 client. Still will not connect. Just bad request.

Not sure what to try next. Want to try to get the Windows clients working first then figure out the WebOs displays. Seems like it must be something on the CMS side since multiple clients of different types all stop working.

What should my next steps be?

I would check the following

1/ Change in network hardware sometimes cause changes in settings in the new Router/Switches so you make sure all settings are similar to what you have with the previous hardware

2/ If you setup VLANs in your network, you need to ensure (firewall, port forwarding) that devices can communicate with each others if they are in different VLAN and/or Main LAN. In our case for example, we put the CMS Server and Display in 2 different VLANs and config the firewall to allow them talking to each other

3/ Update and Restart the CMS server.

4/ Remove all Display and Re-add them back again