CMS installations on windows 10

To be completed by the original poster:

CMS Version

I tried to install the 3 versions - - 2.3.16 / 3.2.0 / 3.2.1 - yet all with the same result.

Installation Method

I found several articles on xibo support that Docker is no longer supported on Windows platforms so I uses Xampp instead as recommended by several Xibo CMS installation documents, and I used Xampp version 5.6.4

Operating System

operating system is windows 10 professional 64 bit.


I followed every guide on the community yet I am still having an issue with the ZeroMQ installation, I followed word document “Steps_to_installing_Xibo_on_an_Microsoft_OS” available from the community, also I followed the PDF file “ZeroMQ installing V1.4.pdf” also from Xibo community, in all case when I try to run the “php xmar.phar” command I get the following error in the cmd screen:
“C:\Windows\system32>php c:\xampp\htdocs\xibo\vendor\xibosignage\xibo-xmr\bin\xmr.phar
[2022-10-25 22:04:02] xmr.INFO: Starting up - listening for CMS on tcp:// [] []
[2022-10-25 22:04:02] xmr.INFO: Bind to tcp://Webserver_IP:9505 for Publish. [] []
[2022-10-25 22:04:02] xmr.ERROR: Failed to bind the ZMQ: No such device [] []
[2022-10-25 22:04:02] xmr.ERROR: #0 [internal function]: ZMQSocket->bind(‘tcp://Webserver…’) #1 phar://C:/xampp/htdocs/xibo/vendor/xibosignage/xibo-xmr/bin/xmr.phar/vendor/react/zmq/src/React/ZMQ/SocketWrapper.php(114): call_user_func_array(Array, Array) #2 phar://C:/xampp/htdocs/xibo/vendor/xibosignage/xibo-xmr/bin/xmr.phar/index.php(98): React\ZMQ\SocketWrapper->__call(‘bind’, Array) #3 phar://C:/xampp/htdocs/xibo/vendor/xibosignage/xibo-xmr/bin/xmr.phar/index.php(98): React\ZMQ\SocketWrapper->bind(‘tcp://Webserver…’) #4 C:\xampp\htdocs\xibo\vendor\xibosignage\xibo-xmr\bin\xmr.phar(10): require(‘phar://C:/xampp…’) #5 {main} [] []”

I installed all the Visual C++ versions as requested by the PDF document, downloaded the exact copy of the ZeroMQ library as per that PDF document, and tried everything yet I still get the same error as above.

Aso when ever I open a browser and type “http://localhost/xibo” I do not get the installation screen, I get a screen showing the folders and files inside the xibo folder, although my Apache is running fine and I can get to and xampp dashboard.

Can you please guide me to what is the problem in my setup, or to an up to date step-by-step setup guide that I can follow to in stall the xibo CMS windows serve.

thanks for your help and support

Which PHP version are you using?

If you look at the requirements, it has to be atleast 7.2.9.

I did not install any specific PHP, I only installed the Xampp and it automatically installed PHP.
The PHP that came with the Xampp when checked with http://localhost/dashboard/ came back to be 5.6.4, and when checked with the xampp control panel ( pressing the Admin button in the Mysql row on the xampp control panel) it shows under PHPMyAdmin the version is 4.8.5
If we need to install a newer version of PHP can you please let me know how to do that without ruining the rest of the xampp installation or do I need to install a new version of xampp in total??
Also where to download a credible newer version of PHP

I can only suggest that if you really want to stick with local CMS, use Ubuntu instead.
But in order to use Windows with XAMPP. I have limited knowledge about that.

I quick google with the keywords Xampp php 7.2.9 leads me to this website, search for the php version and install the xampp. XAMPP - Browse /XAMPP Windows at

Let us know if this helps!

Hi Vishal
After a lot of trials all day long, I can successfully start PHP, and when running the command line with the following command
“PHP c:\xampp\htdocs\xibo\vendor\xibosignage\xibo-xmr\bin\xmr.phar”
I get the result
“xmr.INFO: starting up - listning for CMS on tcp:// [ ] [ ]
xmr.INFO: Bind to tcp://*:9505 for publish. [ ] [ ]
xmr.Debug: Adding a que processor for every 5 seconds [ ] [ ]
xmr Debug: Heartbeat …[ ] [ ]”

and it continues with the heartbeat, and the PHP has started and running.
yet when opening a browser and typing “http://localhost/xibo
I get the page where it shows the content of the Xibo folder showing folders inside it, not the installation screen.

Any help how to get to the installation screen of xibo???
manually install xibo now that zmq is running, php is running, apache and mysql is running.

thanks in advance for your help and support

Hi Vishal
now I got a stage further I already got the “Welcome to the Xibo installaition” page to run by opening the “web” folder on the folder list page when I write the URL “http://localhost/xibo
I cleared all the marks and I have all the items checked on the page.
When I push “next” I get a blank page “this page isn’t working” and the URL on top is showing a very strange address:
with the word install repeated many many times.
Any help??

Hi Hany,

I am having a same infinite loop url.


Have you solved it? please guide me

@admin1 @admin123
if you all are admin, kindly make it easy package for xampp and easy guide.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.