CMS email problems ... again

Hello
i am running Xibo CMS 2.3.7 Inside a hypervisor VM based on Ubuntu 18.04 standard.

I am having problems with the e-mail settings and functionality.
Upon installing the docker I have configured the config.env file with at this point every possible combination of settings and yet i can not use TFA nor Stats / error mails.
The mail server that I use is in a hosting company and i had them give me all possible combinations of server-name/domain name and i still cant make it work.

The hosting company provides me with two options to use mail:
server##.hostingCompany.com
or
mail.DomainName.com
They do not use SSL/TLS for the outgoing (i was advised not to use it anyway)
And i have tried most of the possible port numbers.

The settings bellow are the ones that i use on my phone and other mail clients yet Xibo does not seem to like them. I really dont want to use google.
My current config is as follows:

SMTP Server Hostname

CMS_SMTP_SERVER=server##.HostingCompany.com:25

SMTP Username

CMS_SMTP_USERNAME=Username@MyDomain.com

SMTP Password

CMS_SMTP_PASSWORD=Password

Use a TLS Connection YES/NO

CMS_SMTP_USE_TLS=NO

Use a STARTTLS Connection YES/NO

CMS_SMTP_USE_STARTTLS=NO

Rewrite domain (the domain your email will appear to come from)

CMS_SMTP_REWRITE_DOMAIN=MyDomain.com

Hostname that we should identify ourself to the remote server as

CMS_SMTP_HOSTNAME=server##.HostingCompany.com:

Can the From line be overridden in the outbound email

NB GMail will rewrite the From address anyway so it’s not important

for GMail - YES/NO

CMS_SMTP_FROM_LINE_OVERRIDE=YES

The second trouble is that I have enabled a Password recovery by mail.
Whenever I try and test password recovery it just says “User not found”. I assume this is due to the mail trouble.

Any help/Advice is much appreciated!

It’s very unlikely they are running authenticated SMTP on port 25, so I suspect this is wrong.

The SMTP server is unlikely to accept a connection from you where you announce yourself as the server itself. It’s like saying “Hello, my name’s aster” if I’m talking to you. You’re going to know something isn’t right. You should use the fully qualified domain name of your server, and it should not have a colon on the end of it.

If you’re only going to be delivering email to yourself, then you could try setting CMS_SMTP_SERVER to server##.HostingCompany.com:25 and then commenting out CMS_SMTP_USERNAME and CMS_SMTP_PASSWORD. As long as the mailboxes you’re sending messages to are on the server you’ve specified, then no authentication is required anyway.

Fundamentally you need to get your mail provider to give you valid email settings, put them in to that file, then down / up the containers for those to apply.

Got it sorted out.

Actually the reason was both good and bad.
The good part is that my hosting company is pretty good in protection.
The bad part was that I am an idiot - a simple mistake Port:25 instead of 26 for unsecured connection.
Due to repeated attempts I blocked my IP address from their systems - thus why nothing worked.

Thanks for pointing me in the right direction :slight_smile:

The Xibo Community site uses cookies. What are cookies?