CAS Authentication

To be completed by the original poster:

CMS Version

3.0.0

Installation Method

Custom install

Operating System

Centos 6.10

Issue

Hi,
I just upgraded Xibo to version 3.0.0 and CAS authentication doesn’t work anymore.
When I click on “CAS Login” button, I get “Error : Internal script failure”.
I ran the debug to collect data, and I can read : “/xibo/cas/login,POST,“Route excluded from CSRF: /cas/login”,INFO” from the log.csv file.
If someone can help me to see clear, I would appreciate.

Moreover, is it possible to run a more detailed debug for CAS auth’ ?

Thanks a lot.
François.

Hi, i have the same error (Migration 2.3.9 to 3.0.0 failed - #6 by Tony.J) and i didn’t found a solution…

Hi, Anybody can help us with CAS Authentification who doesn’t work anymore ??
I have try to install the last 3.0.2 but i the same error…
Thanks alot.

Hi, Anybody can help us with CAS Authentification ?

After modifying the code to enable debugging for phpCAS it gave me better error message. It didn’t like the server port being passed as a string.

Try removing the single quotes from around the port address in the settings file, restart your web server, and try logging in again.

FYI I also noticed that I needed to add users in the webui before they could login. CAS authentication does not automatically add new users.

Thank you for bringing this to our attention, an issue has been logged here:

Hi,
Indeed it’s works :). Thanks for your answer.
Tony

The Xibo Community site uses cookies. What are cookies?