CANVA integration successful but error on publish design

To be completed by the original poster:

CMS Version



I’ve been trying out the CANVA integration, however there is an error right at the end.

However when I check in XIBO afterwards the media is imported and I have an empty layout without any media


1 Like

I have the same error.

Perhaps it has to do that I have not setup a secure connection to my Xibo CMS.
I read at the F.A.Q. (down below) that it is not possible to publish designs over http.

I’m using https, the strange thing is that the media uploaded, Xibo told me to ask Canvafor support but I still think it’s a problem involved in Xibo

Thanks for reporting this - we will take a look and get back to you.

We’ve found a few issues, one with SAML enabled CMS instances and the other a general v4 issue:

If you are not effected by the SAML issue, the general v4 issue should be solved, but you may need to enable the correct scopes in the “Sharing” options of the Canva Application.

We have found another issue with the scopes edit form, but it is just visual. If you go in there and grant full access and save, then the integration should work.

Hi Dan,

Thanks for your reply,
For now there is any workaround or we need to wait for CMS 4.0.5?

We deployed a fix yesterday:

If you try again and it still doesn’t work, you could go to your Applications in the CMS, find the one for Canva, edit it and enable “Full access” in the sharing section:

It won’t look like it saved if you reopen the form, but it has.

Thank you Dan!

Worked like a charm

1 Like

I’m having a similar issue but this did not resolve it for me.

I have SAML enabled – CMS v4.0.7

I have that in the log output – the slides show up in media as JPEGs (as selected in the export) – it appears the something to do with tagging as well as layout creation is crashing it out