Can't register screen with server

Hi,

I am having an issue with registering a screen on xibo 1.4.1, It used to work with when on another computer running the windows client, but on the new one it seems to be picked up by the server but no data is registered with the server here is a screenshot form the log
http://imgur.com/PpjCdCy

Is the Player definitely of the correct version for that CMS - ie you’re not trying to use a 1.7 series Player with a 1.4 series CMS?

Also check that you’re not trying to register a Player with a name the same as one of your Display Group names.

Hi Alex,

Yes I am using the correct client software and the screen name is unique

It’s not that the display name is unique (although it does need to be). It’s critical that the display name isn’t the same as a display GROUP name.

Hey there,
I believe i’m seeing the same issue (but do correct me if not). I just upgraded from 7.1 to 7.4 and i seem to be unable to register new clients. The CMS runs on a Windows server and the client also is a windows (8.1) client running the correct (1.7.4) client.

When i click “Save” on the client, i get “Display is awaiting licensing approval from an Administrator”. However, the machine entry does not appear in the “Displays” list in the CMS. The Log shows:

788827 15-09-17 09:28:09 CMS Data Class: Error Number [25004] Error Message [Cannot find display record]

I generated a “troubleshoot.txt” file and the only thing odd that i can see are a few erroneous entries for non-existant and un-named displays. These don’t appear in my list in the CMS and i wonder if this is my problem?

DisplayID: 15
Display:
Default Layout:
Logged In: 0
Last Accessed: 1442403025
Interleave: 0
Licensed: 0

DisplayID: 16
Display:
Default Layout:
Logged In: 0
Last Accessed: 1442476854
Interleave: 0
Licensed: 0

DisplayID: 17
Display:
Default Layout:
Logged In: 1
Last Accessed: 1442478234
Interleave: 0
Licensed: 0

I did used to distribute a pre-built config file with the client installer which omitted the hardware key and the station name, which Xibo replaced dynamically during registration. Although this worked in 7.1, i wonder if the 7.4 client no longer replaces a blank name with the computername… As it stands now, i can add new clients even with no distributed xml file.

Thanks in advance

So, i loaded phpMyAdmin and deleted the display record for the machine with the same “HardwareID” but no name and now i can register that machine.

Though i suspect my cause is different, i wonder if the effect might be the same for @ashs?

You really shouldn’t edit the database directly like that. The Display Record will be linked to a Display Group record which may now be orphaned.

What’s likely happened is you’ve tried to add a display with the same name as a display group at some point previously, which has left a record with that hardware ID which has no associated display group record.

You need to ensure you keep your display and display group names globally unique.

Understood. I have a backup, but i see no other way to remove these “orphaned” entries as they don’t appear in the CMS and they are effectively stopping me from adding the actual machines.

I’ve checked the “DisplayGroup” table and there aren’t any orphans for those nameless entries.

FYI all my Displays are named “XIBO-xxxxx” so there is no chance of a Group / Client name clash.

I think my issue is certainly that i’ve tried to register a client using an xml file with no name entry (as i used to do successfully) and it has created a broken display entry.

Cheers for advising on the DB-edit naughtiness though.

Matt

It’s fine. Editing it when you know what you’re looking for is fine, but someone else might then come along and read your post and decide that randomly pulling entries out of the display table is an OK thing to do :smile:

Glad you’re sorted in any case. Your scenario sounds plausible - ie that a blank name was added and that a corresponding display group therefore wasn’t as the database constraints would prevent that happening conceivably - hence you ended up with an orphaned record.