Can't find settings-custom.php file

Hi, i have zero experience with docker and have issues finding my settings-custom.php file.

Our manager deleted our Azure Enterprise Application which disabled our Xibo Digital Signage.

I’m following this guide to setup the application again.

However, on the step to edit the settings-custom.php file I’m stuck. I can’t seem to find it.

I’ve used this command to list the directories inside the containers :

sudo docker exec -it 6cac947876d1 ls
Output : bin lib root tmp dev media run usr mnt sbin var etc mod_xsendfile.c srv home proc sys

When I run sudo docker ps i get these containers :


  1. 6cac947876d1/xibosignage/xibo-cms:release-2.0.1/“/”/5years ago/up 2 hours/>80/tcp/xibodocker185_cms-web1

  2. bb55904b989e/xibosignage/mysql:5.6/“docker-entrypoint.s…”/5years ago/up 2 hours/3306/tcp/xibodocker185_cms-db_1

  3. a0a3b6807c79/xibosignage/xibo-cms:release-0.7/“/”/5years ago/up 2 hours/>9505/tcp,50001/tcp/xibodocker185_cms-xmr_1

Could someone explain me how i can access my settings-custom.php file? Because when I run the docker exec ls command I can’t seem to find the shared directory.

Kind Regards

You can’t get into the container.

Stored into shared folder.
Usually in the /opt/xibo/ folder, if you have used the official Xibo documentation.