Cannot access CSM from Seperate Offices

CMS Version

Version 4.0.12

Player Type

Amlogic DSCS95 - Purchased direct from XIBO

Issue

We have 2 Displays in different cities setup on the same license and CSM.
We are able to access both displays using the CSM from our main office. However, there is an error occuring when we try to login to the CSM from the new office location. The UI for the CSM breaks.

To help diagnose the ERR_INCOMPLETE_CHUNKED_ENCODING error, please provide the following:

  • PHP error logs
  • Apache/Nginx logs or similar
  • PHP resource limits, especially:
    max_execution_time
    max_input_time
    output_buffering
    post_max_size
    default_socket_timeout

As for now you can check the following:

  • Ensure there is sufficient free disk space on your server (e.g., in the temp and /var directories) and on the client.
  • Check your server-side caching configuration, such as Opcache, for potential issues - disable it and check if the problem still occures
  • Has this site Load-Balancer/Reverse Proxy configs with additional forward rules, different Antivirus settings?

We’re running it using the Docker deployment method, and the php logs have all shown status 200 for the problem file. It was a clean Ubuntu 22.04 VM and I followed the docker install instructions as per the documentation. No load balancer/reverse proxy, and it’s using the default Xibo server side caching too.
This is what I’ve tried tweaking for config.env variables so far. I gave it fairly high limits to see if it would fix the issue but no good so far.
CMS_PHP_POST_MAX_SIZE=4G
CMS_PHP_UPLOAD_MAX_FILESIZE=4G
CMS_PHP_MAX_EXECUTION_TIME=64000
CMS_DEFAULT_SOCKET_TIMEOUT=3200
CMS_APACHE_TIMEOUT=3000

The vendor.bundle.min.js file is getting truncated when tried to access from either off our VPN or from a branch office.

I can’t figure it out based on the information provided, but maybe another user here can help.

However, my debugging approach would be to change/set output_buffering = 8192 in the php.ini file (also try using the value On instead of an integer) and see if the problem persists after restarting the web server and PHP - in your case, just the Docker containers.

Note: The problem will definitely lie elsewhere, not with the buffer size. Still, it might help in this case. For production, 4096 is generally a optimal value; setting it to On here is only for debugging purposes

Can that be changed via the config.env file for docker? or am I going to have to switch to an Apache install?

I don’t use Docker myself and haven’t found detailed info on the parameters you can set in the config.env file.

You don’t need to switch to an Apache setup; you can adjust the PHP settings in your Docker installation. For PHP 8.1, you can find the default configuration file at /etc/php/8.1/fpm/php.ini. The parameter you’re looking for should be close to the top of the file.

Dont forget to restart :slight_smile: