Cannot acces Taskmanager on Win10

I run the latest windows player (installed with xibo-client-1.7.9-win32-x86.msi) on my PIPO mini PC with Windows 10.
All runs well, but i cannot acces the task manager anyone to kill the player and watchdog, and do some maintenance.
The moment I press Ctrll-Alt_del i can acces windows but when i select task manager, XIBO takes over again.
Anyone has a solution for this ?

So task manager should actually be on top of it, but have no fear there are other solutions.

When you press ‘i’ on your keyboard to show status window, it should also disable the ‘always on top’ feature of the player.

Good old alt+F4 will close Xibo player as well - you will need to close watchdog from sys tray as well, as it will restart the client.

Peter, thanks very much. I am not a windows user anymore so I lost out on those commands.
But now, the issue is that when I start de mini pc, XIBO is started but does not grab the focus. So i am left with the tiled login screen of windows. The moment i select an app, then XIBO shows up and not the other app (for instance explorer)
Actually it is not windows 10 but windows 8.1 i discovered. (thought i had upgraded but obviously not)

If you could help me out here again, i would be very much obliged.


I guess the question is, do you want Xibo to start with Windows?

If not you can disable Xibo on startup in Windows task manager - for details with screenshots please see How To Disable Windows 8.1 Startup Programs

Then Xibo will not start automatically and you will be able to start it when you need it.

hmm that’s odd, would it be possible to grab a screenshot of that please?

Essentially if Xibo is set to start with Windows, then once it starts it should have focus and be always on top.

One more thing regarding Watchdog, if you’re using this PC to other things and not only for Xibo, you might want to disable the Watchdog so it doesn’t restart Xibo client when you close it - The Windows Player automatically restarts itself / Windows Player Watchdog

After i changed that windows starts into the desktop instead of into the start menu, all works fine.
And no, this pc does not do anything else. I have removed much of the unwanted and unnecessary applications. I am now monitoring the screen and all seems to behave well, also after a couple of remote re-starts. Thanks for the help any way.

Pressing ‘i’ and then using Task Manager worked for me. Peter (and team) - you guys are the BEST!!! :slight_smile: