Blank dashboard after upgrading CMS (2.3.5 -> 2.3.8)

CMS Version

2.3.8

Installation Method

Custom install (Apache / PHP 7.4 / Mysql)

Operating System

Ubuntu Server 18.04 LTS x64

Issue

After upgrading CMS from 2.3.5 to 2.3.8, I get the home dashboard page empty. Still have widget spaces but not filled with data.

I ran an issue tracker and get some infos in the troobleshoot package :

logId,runNo,logDate,channel,page,function,message,display.display,type
82721,27dd2df,“2021-01-11 10:40:01”,CONSOLE,/,GET,“Error: SQLSTATE[42000]: Syntax error or access violation: 1055 Expression #3 of SELECT list is not in GROUP BY clause and contains nonaggregated column ‘digiplus.layout.layout’ which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by”,ERROR
82722,27dd2df,“2021-01-11 10:40:01”,CONSOLE,/,GET,“SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column ‘message’ at row 1 Exception Type: PDOException”,ERROR

Could you help me to solve this issue ?
Have you ever encountered this type of issue ?

Precedent upgrade went OK with no issue with same method. I don’t understand why become creepy this time.
If no solution here, is there a method to deploy a clean new version with old database import ?

Currently have 48 customers awaiting for me to solve this asap. How starting week and year with stress :grimacing:

Thanks for feedback and Best wishes for this New Year

PHP 7.4 isn’t supported yet, so that may well be an issue.

What version of MySQL are you running. If it’s MySQL 8 then again not supported yet. 5.7 is the latest we support.

When you upgraded, did you delete the existing CMS files (except the library and settings), or did you just copy over the top?

Hi, thanks for quick reply.

I found a solution : to solve the sql issue I tried to add an instruction inside mysql.conf file (/etc/mysql/mysql.conf.d/mysqld.cnf).

In the Basic Settings block, I added :
sql-mode=""

It seems when some queries contains group by we should only select columns from the table we are grouping by, but if not, we ought to use the any_value() function to call the columns from other table.

I mark this post as RESOLVED if it should serve anyone to solve this issue.

Thanks

Could you tell me what MySQL version you’re running please?

Hi Alex, my version is :

mysql Ver 14.14 Distrib 5.7.32

Thanks. I’ve opened an issue here for this to be looked at:

The Xibo Community site uses cookies. What are cookies?