Android on PC install?


#1

I’ve been testing an installation of Android 8.1.0 on an old desktop PC and so far everything seems pretty good. I’ve resolved some of the RTSP streaming issues I had, but there are still some thing to figure out there. In the meantime while testing those streams I’ve noticed that I cannot get the Xibo Player for Android to fill the entire screen. If I am running the Android desktop, I get full screen, but as soon as I launch the Xibo Player, the right side of the screen and the bottom are clipped as you can see in the image where the Xibo logo display in the bottom right while the content is loading. You can also see in the image with a test layout as well. Note however, that I have modified the region with the weather module and the RTSP stream to line up as closely as I could to what appears to be where it clips.

After reading another post about this same issue, I went in to Display settings and modified the location in the Android Display to 0,0,1920,1080. I have also gone into display settings in Android, but there is not anywhere I can find to modify the display settings and I’m not even sure that would matter since the Android desktop displays fine, it’s just the Xibo player that gets clipped.

Suggestions anyone?


#2

Hello,
are you using Android x86 for this?


#3

Yes… Android x86 8.1-r1


#4

Just tried this myself and have exactly the same issue.
same bar on the right and bottom.
I think this is just an issue with Android x86… they don’t have any good display options for scaling or positioning.
might try an earlier release and see if it has the same problem.


#5

ok, figured this out.
don’t use the normal version of Android x86…
I just installed CM-x86 14.1 from http://www.android-x86.org/download
it was a little bit more of a pain to install xibo, I had to add a google account, install es file manager from the play store, and then install xibo through that. (maybe i was missing something obvious).
testing my normal layout now (1920x1080) with an html5 clock, dark sky weather, twitter feed and a video playing on a loop. so far so good! fills the screen nicely.


#6

also, just a note, when installing I chose advanced options from the bootloader, then Auto Install on selected disk. this worked perfect on an Optiplex 790 with a 250GB SSD and dedicated graphics card.


#7

That’s great Kyle! Thanks for all the effort. I’ll jump back to this project later today or tomorrow and let you know how it works out for me.