Analog clock not working

I’m running the same layout on two Windows 7 machines.
On one the analog Clock works perfectly.
On the other only the hour and minute handles are showing and are static on 9:00.
I’m running 1.7.0rc1

Please advice

First suggestion, it might be a good idea to update your CMS/players to 1.7.4
Second suggestion, please run ‘verify all’ from your modules page in CMS, give players some time to download modules and see if that will help.

Thank you for your time.
Unfortunatly it’s still not working.
I’ve upgraded both CMS and player to 1.7.4
I’ve run "verify all"
I’ve cleared the local libuary an let it download the modules.
The display correctly shows two videos and date but still the same problem with the analog Clock.
The other display/computer continues to show a working clock

That’s odd.

Are there any differences between your two PCs?
We can exclude the CMS or layout issue, since now you have the newest versions and it’s working on your other PC.
hm, perhaps try this settings for browser emulation

The registryfix did not solve the problem.
But it lead me to a working fix. I upgraded the browser from IE8 to IE11 and that solved it.
Now the Clock is working.
Thank you for your assistance.

Well it’s connected yeah, basically you will want to emulate the version of IE that is actually installed on your machine.
Anyway, I am glad that it’s fine now.