Admin panel does not show Navigation bar

I have a problem with the admin interface in both the Xibo 1.7.4 and 1.7.5 version. The navigation bar at the left side of the admin panel (this one: http://xibo.org.uk/manual/en/tour_navigation.html) does not show up. I only get the text “Dashboard” at the top and the text “Manual” and “About” at the bottom. The navigation bar does not show anything at all. However, urls to the items of the menu are reachable by my account. Through the welcome tour after startup (first time login in admin panel) I can get into the event schedule and display settings. I have tested both Xibo versions with a clean install, after purging the complete database and database account. I also deleted the Xibo web and data folder.
I also tried the new 1.8 alpha version to see it the error still occurs. However, in this release the navigation bar does show up!

I have a self-hosted version on an offline WAMP testserver with following specs:
Windows Server 2008 R2
Apache 2.4.9
MySQL 5.7.10
PHP 5.5.30

Xibo is hosted in https://localhost/xibo/
SSL is always forced on our server.

All required modules for Xibo have been activated (green checks on the install.php page)

I tried to explore the Github page for relevant changes to files /lib/data and /lib/changes, but the sourcecode has changed dramatically with the new version. Therefore, I have not been able to find the bug.

The httpd.conf is close to the default WAMP config. This is a part of my httpd.conf (spaces have been added in directory tags to circumvent removal by text editor):

DocumentRoot “DIRECTORY/wamp/www/”

< Directory />
AllowOverride none
Require all denied
< /Directory>

< Directory “DIRECTORY/wamp/www/”>

Options Indexes FollowSymLinks

AllowOverride all

SSLRequireSSL
SSLRequire %{SSL_CIPHER_USEKEYSIZE} >= 128

< /Directory>

I would appreciate any help very much, I am struggling with this problem for a few days already.

Hi,

1.8 has a lot of changes ‘under the hood’, I am glad that it is fine.

as for 1.7 the general structure of page wrapper and nav sidebar isn’t overly complex.

Sorry for asking about this, but sometimes the easiest solutions are the Best.
Did you try to clear your browser cache or use different browser?

Perhaps you could spot some issues in your web server logs or chrome dev console?

Failing that you could try to set up a demo CMS with Spring Signage and see if everything will be fine

After that we should know where the problem might be (or at least narrow it down)

I understand that you have to ask about the cache and browser.
I have tested the webpage at two PC’s with both IE10, Firefox 43 (with FireBug) and latest Chrome.
No errors or warnings showed up (also in persistent mode). Cache clearing did not help either.

This is what Firefox gets:

The li tags with the classes sidebar-list and sidebar-title are missing.
I am sorry, but I am not familiar with Spring Signage. Could you provide me a link to a tutorial?

Could it be a problem with the rights of the admin account generated by the install.php SQL statements? Can I check those somehow? (I have access to the database, so I can look it up if I know what to search for)

Edit: about the server logs, both the Apache as the PHP log do not list any error.

Hi Jimmy

You should check that the xibo_admin is a superadmin. If so then that user will get all menus regardless of what permissions are in the system for them.

If you visit /index.php?p=user then edit the xibo_admin user you can check there.

Failing that it might be easier to reinstall from scratch. Please ensure you clear the database out so it’s completely empty (or drop it and recreate it) so it’s ready for the installer to use. Also check that you’re using the latest 1.7 download from the releases page in Github.

Hi Alex,

I checked it and my user is superadmin. Also as I stated earlier, I dropped the complete database each time I tried to install 1.7.5, 1.7.4 and 1.8 (alpha 2) as well as the xibo user. I also deleted the xibo www map and the xibo data map.
Only the 1.8 alpha 2 works on my server, if I install 1.7.5 it does not. Are there any specific httpd.conf rules that I need to apply in order to let this work?

No there are no rules required for 1.7.4 or 1.7.5 - they only come in to play with 1.8.0alpha1 and later.

Perhaps the menu items aren’t being populated in the database correctly. Can you check that?

Could you tell me which table I need to check and how many/which values should be there?
Update: as I should mention, I do have access to all items that should be in the menu
e.g. if I type /index.php?p=layout I get the layout overview, if I type /index.php?p=user I get the user configuration.
I can also change the settings on these pages, so it is not a permission problem.

The menuitem table should be per the data.sql file in the distribution:

Thank you for the code. I checked it and I have 36 rows in that table, so that is not the problem.
The table ‘menu’ is also filled with 7 rows. The table ‘pages’ has 34 rows.
Very interesting: I just found that the table ‘log’ is also filled. It contains the following error message multiple times:

The query [SELECT DISTINCT pages.name , menuitem.Args , menuitem.Text , menuitem.Class, menuitem.Img, menuitem.External FROM menuitem INNER JOIN menu ON menuitem.MenuID = menu.MenuID INNER JOIN pages ON pages.pageID = menuitem.PageID WHERE menu.Menu = ‘Top Nav’ ORDER BY menuitem.Sequence] failed to executeExpression #1 of ORDER BY clause is not in SELECT list, references column ‘xibo.menuitem.Sequence’ which is not in SELECT list; this is incompatible with DISTINCT
1024
User Notice
LOCATION\xibo\modules\module_user_general.php
596

Solution: if you add menuitem.Sequence to the select statement, the query will run :smile: Which sourcecode file needs to be adjusted for this? Could you also make a bug report of this?
Update 2:
I edited the \modules\module_user_general.php file on line 571 to:
$SQL .= " menuitem.External, ";
$SQL .= " menuitem.Sequence ";
Bug has been solved. I get the menu! :smile: I do not understand that nobody else has this problem, since the query is not correct…

1 Like

I expect it’s a change in MySQL that’s preventing it working on a newer version but the same query will work as expected on an older version.

Logged as a bug here:

Thanks for your help working through that.

I’ll merge this when I get back

The Xibo Community site uses cookies. What are cookies?