1.8rc-1 API - GET playlist/widget returns nothing on one playlist

I have one playlist out of seven, that will not return anything when called via the API with Get playlist/widget. So far all the others do. Is there any known reason this might be?

I also tried turning on debug in test mode. I get plenty of logs when swapping out media via the api, but nothing at all when calling Get playlist/widget. Bug on the logging?

What’s in that specific playlist please?

I tried to recreate it, but all the playlists I have do return details when I use this call.

Not possible - with the CMS in test mode every query run is logged and if this is working for some calls it must work for all calls.

I think Peter is heading in the right direction, there might be something in that playlist causing an issue.

If you GET /layout for a layoutId which contains that playlist and embed playlist data - do you get anything then?

Not sure what the issue was. Rebooted the server and now the problem is gone. Can’t explain that one.

Hmm, that is strange! If it happens again please let us know.