1.8.0-rc2 -DockerToolBox Win10 - CMS Access outside container?

I have Docker Toolbox installed on Windows 10 and can access the CMS from the host using the container ip .

The host is on network and no hosts on this network can access the CMS for management.

My search for a solution leads me back to the docker run statement -p argument.

Here is mine for the web container.

    docker run --xibo-cms-web -p 8080:80     _{snipped the rest of the command}_

What am I missing to allow the container to be accessible from the network of the host?

I have tried the --net=host and the -p host:8080:80 and still not access to the container from an outside network.

Ideas or links would be appreciated.

Do you have 2 network adaptors? It is not obvious why the container would be bridged to 192.168.99.x unless there was a network adaptor of that subnet.

All containers should be started in bridge mode, so that they get their own IP addresses on the network - perhaps you have a DHCP server giving your “bridged” connection a different IP to your native one?

I have one physical NIC.

When I install Docker Toolbox the install creates two VirtualBox adapters under the windows adapters. One in the address range of and the other Neither of these networks are part of my LAN DHCP ranges. When I view Active Networks in Windows 10, I see only one network. This is my domain network that the PC is a member of.

When I run the docker inspect {code for xibo-cms-web} it lists the ip network as

I am in the process of uninstalling everything associated with Docker and try again. How do I know I have a correct install? WWhat ActiveNetwork in Windows will appear besides my LAN? Will netstat -a from a Windows CMD window show the CMS web site ip:port that it is listening to? What IP range should show in the netstat -a results for the CMS for a default install of Docker Toolbox?

Week three of trying to get this to work. Again any ideas, links or suggestions would be appreciated.

Testing still and found that the .56.0/ network is created with Docker Toolbox is created. and the 99.0/ network is created when the Docker Quickstart Template is ran. It seems that they are default IPs for Virtual Box VM when the DHCP server is not reachable. Since myDHCP server has mac reservations and mac addresses are random in VB VM then I am stuck without this Docker solution for Xibo. Thanks Dan again for pointing me to the DHCP as a possible issue.

My understanding is that one of the network adaptors should be bridged, which means the docker container should fetch an IP from your DHCP server.

@alex - any idea?

I think you need to adjust the network adapter on your VirtualBox VM (in which Docker is running) per this thread:

The intall process of using Docker Toolbox does not use an IP from my DHCP server. It continues to use the IP of either or

I have tested this on a LAN with open DHCP(no Mac Filtering). The DHCP network using addresses does not get any leases from the components of Docker Toolbox, VirtualBox VM or the DockerQSTemplate opening and command of ./launcher bootstrap

When will there be the ability to install the 1.8 version using Docker Toolbox? Some of the other forum posts also mentions this issue yet I am not see a guide this is how it is to be installed.

I noticed in every install the docker inspect {–xibo-cms-web-} shows an entry which seems to be wrong. My launcher.env file does not have any gmail settings.

“ENV”: [