XMR problems, connected but now messeges


i`m running Xibo 1.8.2 on Docker on my VPS. Players are conneted via Internet. Players are registered but now commands are execute on players. Such theme change, thumbnail request, etc.

In CMS state i registered. On client connected to: … Waiteng for messeges.

What is wrong?

if you run the docker ps -a is the xmr container running?

What’s the xmr public address in cms settings?

Are there any logs on the player status window / CMS log page?
You might need to enable CMS debugging / player auditing for more log messages.

Yes, the xmr contianer is running.

baac5579af42 xibosignage/xibo-cms:release_1.8.2 “/entrypoint.sh” 5 weeks ago Up 2 hours>80/tcp xibo2_cms-web_1
4e9665c98ce7 xibosignage/xibo-xmr:release_1.8.2 “/entrypoint.sh” 5 weeks ago Up 2 hours 50001/tcp,>9505/tcp xibo2_cms-xmr_1
5ba22bd87019 mysql:5.6 “docker-entrypoint…” 5 weeks ago Up 2 hours 3306/tcp xibo2_cms-db_1

Public address in CMS is: tcp://ds.mydomain.com:9505

i have turn on debugging and sned the XMR command. I the troubleshot.zip but i cant upload it here.

Can anyone help me ??? :frowning: :frowning:

With docker, you should only need to enter xmr public address in CMS settings, assuming that is correctly entered there, player should be able to reach it.

If they can’t then there should be log messages about it, especially if as you say you’ve enabled debugging/auditing on the player.

Can we perhaps see a screenshot of status window on your device please?

The player hav connection with CMS but no commends are sending to player. It`s possible that is a communication error betwwen cms container and XMR ?

I see it’s in audit mode now, if you’d, for example, request a screenshot from this player, is there any relevant messaged logged for it on the status window / CMS log page?

Also if you send a command to this display, perhaps something simple like notepad.exe (the command string is added in display profile assigned to the display - http://xibo.org.uk/manual/en/displays_commands.html)

Then in config.xml file (it’s in the player local library) there should be your commands listed there in <commands> line, could you check if that is correctly sent as well please?

Failing that, could you run docker-compose log ?

You may need to redact any passwords or sensitive information in the output of that command before posting it here, alternatively send it to me via private message.

When i request command nothing happend on player and there is now messege in status windows.
I send you files in PM.

Commands are added to your config.xml ie they were sent to the player, but presumably not executed - as mentioned it might be better to test it with notepad.exe just so when it works it won’t shutdown your PC.

Actually could you open Display Settings -> Edit display profile assigned to your device and let me know what do you have in Download Start/End window please?
It seems to be set to 0, while it should be 00:00, there was a bug about it, but it should be correct in 1.8.2 version, although please do double check that.

There seems to be some issues with XMR connection, it was stopped and disconnected according to your logs.

Could you navigate to Displays page -> Edit your Display -> Advanced tab -> Reconfigure XMR (Enable & Save the form), perhaps restart your Xibo player after that as well.

I will also be watching this topic, as I seem to have exactely the same problem.

I have here 00:00 and 00:00

I have reconfigure and rebooted. Nothing change.

Actually I think I’ve missed something important from your earlier posts.

XMR container seems to be configured to listen on port 65500 not 9505

You will need to either change the compose file so it’s on 9505 instead of 65500, or change the public address in cms settings to 65500 port ie they need to match.

Could you try that please?

I have change public XMR adress port to 65500 and it`s working!!
Only screenshots are very small but i dont know why :slight_smile:

i use cms_custom-ports.yml when starting xibo thats the mistake?

Display Setting Profiles → Screen Shot Size

It’s not a mistake, if you’re using custom ports then that’s what you should be using, the ‘problem’ was that what you had in CMS settings wasn’t matching your custom ports, once you’ve rectified that then as expected everything works well.

Regarding screenshots size, what hhan said.