XMR issue with docker

Hi All,

I am using the Xibo API to change layouts. After playing with the API for a bit I see the following error in the CMS logs:

/displaygroup/18/action/changeLayout	Player action connection failed. E = XMR connection failed. Error = Failed to connect the ZMQ: Protocol not supported

I’m using port 9505 for XMR and I see the docker instance is running.

Any ideas on what to do now?

what do you see if you try to run xmr directly in the console?

I assume it’s still correctly configured in CMS settings?

If you’d request a screenshot for example, does that work?

Since it is already running, did doesn’t bind on the port. I can kill it and try, but what’s the best way to do so.

I believe I configured it correctly in the CMS. I did change the XMR setting on first boot. Also, the screen shot feature doesn’t work. It gives the same error.

Question, can I use the public Ip in the private and public XMR address fields in the CMS?

The CMS sends private messages to XMR and the players get published messages from XMR.

If you’re using docker then I believe the private address is configured for you and you only need to adjust the public address which usually is
tcp://domainName:9505 or tcp://IP.address.:9505

ie the ip/domain that you use in browser to connect to the CMS page.

Checked and XMR is configured correctly from the cms.

Ok. I got the XMR up. but now, I see the following error:

Player action refused by XMR (connected but XMR returned false).

What should I be looking at?

If it’s correctly configured (the public xmr address) then perhaps some firewall is blocking the connection?

Have you changed anything regarding private address?
If so what’s your current private and public xmr address in CMS please?

Thanks peter. I had the private XMR address set to localhost but it seems it needed to be set to the private ip of the docker container: Everything works now.