Xibo Ubuntu 18.04 Autostart


We are running Xibo on ubuntu 18.04 and yesterday when xibo updated to 1.8-R4, the Ubuntu Autostart stopped working. Xibo no longer starts on boot. When launched manually, it still starts as normal.

We have tried multiple different methods of trying to get xibo-player to autostart. Such as: adding a delay to the autostart command or trying to autostart xibo via systemd as opposed to the StartupApplications built into ubuntu, however none of them have worked.

Does anyone have any clue as to what might be a potential fix to this issue?

Installed ubuntu and xibo on a fresh machine to test whether this is going to be resolved and getting the following error while trying to run xibo-player on the fresh machine:
[1709] [debug]: [DBus] ScreenSaver is suspended: 1417081508 (different number each time)
[1709] [info]: [XiboApp]
[1709] [debug]: [XiboApp] Player settings updated
teminate called after throwing an instance of ‘Gdk::PixbufError’
Player exited with code 6

im getting this too on fresh ubuntu boxes but i also get the error when manually launching it

This new version doesn’t work.
Give us the old 1.8 R3 please, we need it for to work correctly.

Thank you for your messages about this issue. I have also been testing this issue on my own Ubuntu 18.04 install and can confirm that my own R4 Player is not starting automatically. This has been reported to the development team to work on a fix. My apologies for any inconvenience caused.

If you have upgraded your R4 player from R3, you may find you can revert to a previous revision by using the following command:

snap revert <revision number of a previous install>

Many Thanks.

Further to my previous message, discovered that a new member of the forum has found a workaround that resolved this issue in the meantime on my own 1.8 R4 Player.

I wondered if any of the above users reporting this issue have tried setting a Width and Height for the Player in the Display Profile you are using with your Linux players? Then wait for the Player to collect one more time so the settings have been received and restart your Ubuntu machine.

I would be interested to know if the issue persists for any users experiencing this issue after doing this.

Many Thanks.

Setting the width and height worked for me.

Hi GS_IT, welcome to the Xibo Forum!

Thank you also for confirming that with your setup this also resolved the issue. I will be sure to include this in the notes for the issue.

Many Thanks.

i tried making a copy of my Linux display settings profile and changing one Ubuntu display to use that profile. I set the width and height as recommended. I still continue to get the following repeating error when starting the player manually:

[08:53:12.007] [2853] [debug]: [DBus] ScreenSaver is suspended: 1557447748
[08:53:12.008] [2853] [info]: [XiboApp]
[08:53:12.023] [2853] [debug]: [XiboApp] Player settings updated
terminate called after throwing an instance of ‘Gdk::PixbufError’
Player exited with code 6

Setting the width and height worked for me.
it’s a short-term solution.

Thank you Tony.J for confirming that the Width and Height settings is working while the issue is investigated and resolved.

Many Thanks.

Hi gitthismoney! Some Users have found that updating your Ubuntu install using the sudo apt-get update command, then restarting the Xibo player has resolved the Gdk::PixbufError. Can you also update your Ubuntu install and confirm if the error is resolved?

Many Thanks.

appreciate the help!
i tried sudo apt-get update / sudo apt-get upgrade and rebooted but the PixBufError error persists…

after the updates I tried sudo snap remove xibo-player / sudo snap install xibo-player, ran xibo-player.options to configure the player and ran the player but the issue persists…

the machines im using are fresh ubuntu installs very strange!

Setting the screen size has fixed the issue.

Before your response, we found out that xibo autostart worked after clicking the mouse button - so we set up an autoclick script at startup to click a few times, which had us working for the meanwhile.

Thanks rmas, I appreciate you passing on confirmation that setting a screen size also works for you.

Very clever by the way with the autoclick script, an interesting workaround.

Many Thanks.


i got the same Problem with Autostart.
I would like to try the Workaround with Setting the Widht and Height but I am unable to locate where to set it up.

Can someone try to help me.

It’s in french, but this options are in a same place.
After you need to start your player manually, wait 1 minute and reboot.

thanks for your help but in my Xibo I don’t have the Option for Linux Profilesettings to set the height and widht.

Is there Maybe something wrong in my Xibo Installation?

Hi Bruder_Bruno. I can see in your screenshot that your Linux Profile is incorrect. Below is a zoomed in version of your screenshot showing that your Profile named Linux is actually an LG/webOS Profile, you can see it says lg where I’ve highlighted it with a blue arrow:

This suggests that you do not have a Linux Profile, which could explain the issues you are having. What version is your CMS? If you are not using a CMS of version 1.8.13 or higher, you first need to upgrade your CMS before proceeding.

If you are already using a 1.8.13 or higher CMS version, you should find that when you click the Add Profile button in the top right corner of the page, you should have the full list of Profiles available to you as shown below. You need to choose Linux as the client type, not webOS:

Many Thanks.

Hello DanBW,
my CMS is 1.8.9.
So I will go for an Update first and then I will try it again.

Didn’t know my Version wasn’t up to date. My colleague told me, he had updateted the CMS but maybe not to the latest Version. So I will look into it.

Many Thanks. :slight_smile:

now with CMS 2.2.1 I can set the right Linux Displayprofil and also I can set die Display height and widht.
At first I had a small problem that the Ubuntu taskbar was shown but that fixed it self after a short time.

Many thanks to all of you.