Xibo player not downloading new files [SOLVED]

Dear support,

First some info
CMS server latest docker image on LAN - Ubuntu 16.04 docker installation with apache2 SSL proxy
Player 1.8.9 is running on a windows 10 device.


Players added to the system are recognized and authorized but they are not downloading new files. It seems although they register, they seem not able to reach the media content.

Any thoughts please?
CMS display page

CMS Server docker process and tcpdump on port 9505

Player screenshot - note that 133 files to download always stays the same.

Apache2 config for SSL: (Certificate = globalsign certificate so not a private generated one.)
<VirtualHost *:443>

SSLEngine On
ProxyPreserveHost On

# Set the path to SSL certificate
# Usage: SSLCertificateFile /path/to/cert.pem
SSLCertificateFile /etc/ssl/private/company.com.cert
    SSLCertificateKeyFile /etc/ssl/private/company.com.key
    RequestHeader set X-Forwarded-Proto "https"

    SSLProtocol -all +TLSv1.2
    SSLCipherSuite "ECDHE-ECDSA-CHACHA20-POLY1305-SHA256:ECDHE-RSA-CHACHA20-POLY1305-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:DHE-RSA-AES128-CBC-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:DHE-DSS-3DES-EDE-CBC-SHA:AES128-SHA:DES-CBC3-SHA:!CAMELLIA:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4"
    SSLHonorCipherOrder on
    SSLCompression Off


    ErrorLog /var/log/apache2/xibo-error_log
    CustomLog /var/log/apache2/xibo-access_log common


# Servers to proxy the connection, or;
# List of application servers:
# Usage:
# ProxyPass / http://[IP Addr.]:[port]/
# ProxyPassReverse / http://[IP Addr.]:[port]/
# Example:
ProxyPass / http://127.0.0.1:8080/
ProxyPassReverse / http://127.0.0.1:8080/

    </VirtualHost>

I believe the config looks fine.

You could try clearing display cache (Edit and Save display record in CMS) and see if that will help.

If not, you’d need to look in CMS log page for the RequiredFiles that this player reports - it should call that on every collection interval.

Could you also confirm that https://digitalsigange0301 is the complete URL for the server?
That seems to be what you provided in the Player settings, but then XMR has https://digitalsignage0301.priv.vangenechten.com

The URL in player settings must match the URL in cert, otherwise it will not work, perhaps worth double checking that as well.

Hi Peter,

  • Unfortunately the clearing of the display cache didn’t help
    but …
  • I adjusted the URL to https://digitalsignage0301.priv.vangenechten.com that seems to be doing the trick.
    (Why doe I use the FQDN: because the globalsign certificate is a wildcard certificate and as such only matches on the FQDN.)

damn, now I feel a bit …

Thanks a lot Peter!
Kristof

1 Like