Xibo login issue

Hi,

We have a redhat linux server with xibo installed.

We have upgraded the php to 5.6 and apache to 2.4.33 recently.

On opening the webserver,http://myserverip/library/xibo/ gives the php code

?php
/*

  • Xibo - Digital Signage -
  • Copyright © 2006-2012 Daniel Garner, James Packer and Alex Harrington
  • This file is part of Xibo.
  • Xibo is free software: you can redistribute it and/or modify
  • it under the terms of the GNU Affero General Public License as published by
  • the Free Software Foundation, either version 3 of the License, or
  • any later version.
  • Xibo is distributed in the hope that it will be useful,
  • but WITHOUT ANY WARRANTY; without even the implied warranty of
  • MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  • GNU Affero General Public License for more details.
  • You should have received a copy of the GNU Affero General Public License
  • along with Xibo. If not, see http://www.gnu.org/licenses/.
    */
    DEFINE(‘XIBO’, true);

// Include the Program Logic
include_once(“lib/include.php”);

?>

Any help would be appreciated.

Thank you for the information. Can you confirm the version of the CMS you are using?

The issue could be related to an issue with PHP, I would recommend checking your PHP configuration in case this is causing the problem.

Another possibility is that PHP is not enabled in your Apache server, can you confirm that PHP is enabled? You could also restart your Apache server.

Once you have tried the above, please let me know if the issue persists or has changed?

Many Thanks.

It is the problem with php module on apache…Is there any other way I can do it ? like virtualhost etc without requiring php.

Now the php is messed up on the server.