Xibo-linux segfaults under openSUSE 15.1

xibo-player 1.8.x segfaults at startup. the terminal window shows “Player exited with code 11”, until I cancel xibo-player.

xibo-cms runs under docker with the following xibo-container versions on the server (ubuntu 18.04):

CONTAINER ID        IMAGE                                COMMAND                  CREATED             STATUS              PORTS                                                        NAMES
f69e18ec3940        xibosignage/xibo-cms:release-2.2.2   "/entrypoint.sh"         7 days ago          Up 17 hours         0.0.0.0:65501->80/tcp                                        xibo_cms-web_1
a891c0544c94        ianw/quickchart                      "yarn start"             7 days ago          Up 17 hours         3400/tcp                                                     xibo_cms-quickchart_1
7724f6364729        mysql:5.6                            "docker-entrypoint.s…"   7 days ago          Up 17 hours         3306/tcp                                                     xibo_cms-db_1
32a93ffd9363        xibosignage/xibo-xmr:release-0.7     "/entrypoint.sh"         7 days ago          Up 17 hours         0.0.0.0:9505->9505/tcp, 50001/tcp, 0.0.0.0:65500->9505/tcp   xibo_cms-xmr_1

OS-version of the client (/etc/os-release):

NAME=“openSUSE Leap”
VERSION=“15.1”
ID=“opensuse-leap”
ID_LIKE=“suse opensuse”
VERSION_ID=“15.1”
PRETTY_NAME=“openSUSE Leap 15.1”
ANSI_COLOR=“0;32”
CPE_NAME=“cpe:/o:opensuse:leap:15.1”
BUG_REPORT_URL=“https://bugs.opensuse.org
HOME_URL=“https://www.opensuse.org/

installed snap versions on the client (I installed the edge version 40 according to another forum thread; the segfault appears also with rev 37):

Name               Version          Rev   Tracking   Publisher    Notes
core18             20200124         1668  stable     canonical*   base
gtk-common-themes  0.1-28-g1503258  1440  stable     canonical*   -
snapd              2.42.5           5754  stable     canonical*   snapd
xibo-player        1.8-R4           40    candidate  xibosignage  -

player messages from journalctl (for rev 37):

Feb 11 14:22:22 lslobby systemd[1]: Mounting Mount unit for xibo-player, revision 37...
Feb 11 14:22:22 lslobby systemd[1]: Mounted Mount unit for xibo-player, revision 37.
Feb 11 14:22:47 lslobby kernel: player[2273]: segfault at 0 ip 0000555bb46fad1a sp 00007ffc36d0ddf0 error 4 in player[555bb44c7000+627000]
Feb 11 14:22:50 lslobby kernel: player[2297]: segfault at 0 ip 0000560cd295dd1a sp 00007ffcb00bd020 error 4 in player[560cd272a000+627000]
Feb 11 14:22:54 lslobby kernel: player[2320]: segfault at 0 ip 000055eacc1cdd1a sp 00007ffeed0154f0 error 4 in player[55eacbf9a000+627000]
Feb 11 14:22:57 lslobby kernel: player[2343]: segfault at 0 ip 00005611cf2a4d1a sp 00007fffa58627f0 error 4 in player[5611cf071000+627000]
Feb 11 14:23:00 lslobby kernel: player[2367]: segfault at 0 ip 0000563479d23d1a sp 00007fffbaa38f40 error 4 in player[563479af0000+627000]
Feb 11 14:23:03 lslobby kernel: player[2390]: segfault at 0 ip 000055e0ef2bbd1a sp 00007ffdd983d810 error 4 in player[55e0ef088000+627000]
Feb 11 14:23:07 lslobby kernel: player[2411]: segfault at 0 ip 00005640251e2d1a sp 00007ffe75a83820 error 4 in player[564024faf000+627000]
Feb 11 14:23:10 lslobby kernel: player[2432]: segfault at 0 ip 0000558565564d1a sp 00007ffe0370cc20 error 4 in player[558565331000+627000]
Feb 11 14:23:13 lslobby kernel: player[2462]: segfault at 0 ip 0000558f879d4d1a sp 00007ffddcad2180 error 4 in player[558f877a1000+627000]
Feb 11 14:23:16 lslobby kernel: player[2483]: segfault at 0 ip 00005557b5e7fd1a sp 00007fffbb5d8210 error 4 in player[5557b5c4c000+627000]
Feb 11 14:23:20 lslobby kernel: player[2506]: segfault at 0 ip 0000562a63851d1a sp 00007ffc174ca770 error 4 in player[562a6361e000+627000]
Feb 11 14:23:23 lslobby kernel: player[2579]: segfault at 0 ip 00005623eff1bd1a sp 00007ffc6d949ca0 error 4 in player[5623efce8000+627000]
Feb 11 14:23:26 lslobby kernel: player[2601]: segfault at 0 ip 000056337434dd1a sp 00007ffcfa59bae0 error 4 in player[56337411a000+627000]
Feb 11 14:23:29 lslobby kernel: player[2627]: segfault at 0 ip 0000564f2beafd1a sp 00007ffec778f980 error 4 in player[564f2bc7c000+627000]
Feb 11 14:23:33 lslobby kernel: player[2648]: segfault at 0 ip 0000556e4f46fd1a sp 00007ffff449d7a0 error 4 in player[556e4f23c000+627000]
Feb 11 14:23:36 lslobby kernel: player[2769]: segfault at 0 ip 0000560d76053d1a sp 00007fffa5891aa0 error 4 in player[560d75e20000+627000]
Feb 11 14:23:39 lslobby kernel: player[2792]: segfault at 0 ip 0000556a58a8dd1a sp 00007ffee714be20 error 4 in player[556a5885a000+627000]
Feb 11 14:23:42 lslobby kernel: player[2817]: segfault at 0 ip 0000561c5fccbd1a sp 00007ffc09772820 error 4 in player[561c5fa98000+627000]
Feb 11 14:23:45 lslobby kernel: player[2840]: segfault at 0 ip 0000560ba6627d1a sp 00007ffecee0e140 error 4 in player[560ba63f4000+627000]
Feb 11 14:23:49 lslobby kernel: player[2863]: segfault at 0 ip 000056151ca17d1a sp 00007ffc4c96c430 error 4 in player[56151c7e4000+627000]
Feb 11 14:23:52 lslobby kernel: player[2886]: segfault at 0 ip 00005594ab2b2d1a sp 00007ffcb7501900 error 4 in player[5594ab07f000+627000]
Feb 11 14:23:55 lslobby kernel: player[2907]: segfault at 0 ip 0000557197b25d1a sp 00007ffc061bbc90 error 4 in player[5571978f2000+627000]

player messages from journalctl (for rev 40):

Feb 12 07:31:01 lslobby systemd[1]: Mounting Mount unit for xibo-player, revision 37...
Feb 12 07:31:01 lslobby systemd[1]: Mounting Mount unit for xibo-player, revision 40...
Feb 12 07:31:01 lslobby systemd[1]: Mounted Mount unit for xibo-player, revision 40.
Feb 12 07:31:01 lslobby systemd[1]: Mounted Mount unit for xibo-player, revision 37.
Feb 12 08:09:01 lslobby kernel: player[2602]: segfault at 0 ip 0000558fe32ee00b sp 00007ffdce17f098 error 4 in player[558fe3100000+50e000]
Feb 12 08:09:05 lslobby kernel: player[2682]: segfault at 0 ip 00005622d618500b sp 00007ffc6fe59d68 error 4 in player[5622d5f97000+50e000]
Feb 12 08:09:08 lslobby kernel: player[2758]: segfault at 0 ip 000055ea17e1500b sp 00007ffce80e7e38 error 4 in player[55ea17c27000+50e000]
Feb 12 08:09:12 lslobby kernel: player[2834]: segfault at 0 ip 000055904e06200b sp 00007ffed2f84cd8 error 4 in player[55904de74000+50e000]
Feb 12 08:09:15 lslobby kernel: player[2910]: segfault at 0 ip 000055f6ebc5b00b sp 00007fff0f09ca08 error 4 in player[55f6eba6d000+50e000]
Feb 12 08:09:19 lslobby kernel: player[2986]: segfault at 0 ip 000055e8e1a8d00b sp 00007fffbfc668c8 error 4 in player[55e8e189f000+50e000]
Feb 12 08:09:22 lslobby kernel: player[3064]: segfault at 0 ip 000055938959d00b sp 00007ffe42738ac8 error 4 in player[5593893af000+50e000]
Feb 12 08:09:26 lslobby kernel: player[3140]: segfault at 0 ip 00005559bbfdd00b sp 00007fff3bf18938 error 4 in player[5559bbdef000+50e000]
Feb 12 08:09:29 lslobby kernel: player[3216]: segfault at 0 ip 000055bb48d9100b sp 00007fff95d33938 error 4 in player[55bb48ba3000+50e000]
Feb 12 08:09:32 lslobby kernel: player[3290]: segfault at 0 ip 000055919326000b sp 00007fffd3bed048 error 4 in player[559193072000+50e000]
Feb 12 08:09:36 lslobby kernel: player[3366]: segfault at 0 ip 000055d48ec9400b sp 00007ffcc2f68068 error 4 in player[55d48eaa6000+50e000]
Feb 12 08:11:06 lslobby kernel: player[3711]: segfault at 0 ip 0000559ee476900b sp 00007ffc97b1c628 error 4 in player[559ee457b000+50e000]
Feb 12 08:11:09 lslobby kernel: player[3788]: segfault at 0 ip 00005642b25a700b sp 00007ffeb8739d88 error 4 in player[5642b23b9000+50e000]

The layout that should show up, consists of 2 regions: a clock and a 3 page pdf file.

Welcome to the community - thanks for posting that - I’ve made a note on the development board to have a look at this once we’ve cleared out some of our other issues.

For clarity - we’ve not tested on openSUSE at all - although I would expect snap to have handled all the dependencies (clearly not!)

Thanks for your reply. After reading your comment, I removed xibo-player and installed rev37 again (before I tried only a refresh). And it works again. But according to my zypper logs, there were no updates of any system components. rev37 did work last week. Can chances in the desktop environment have any influence?

Sorry I am a little confused - do I have the sequence of events right?

  • Installed rev37 - it worked
  • Installed rev40 to try it out - segfault
  • Installed rev37 - segfault
  • Completely remove and install rev37 - it worked

Is that right? If so that is very strange!

We’re building another revision soon which has some more fixes in it for video (we hope - its a new version of gstreamer), so it would be very interesting to see if that also causes the segfault.

  • installed rev37 last week - it worked
  • this week - trying some modules - it segfaults
  • refresh rev37 - no change
  • looking for a solution - found reference to rev40 -
  • installed rev40 (didn’t remove rev37 before) - segfaults as well
  • removed xibo-player ( does that remove every occurence ?)
  • installed xibo-player (stable rev37) - it works

Modules I tried were “shell command” and “show webpage” but it segfaulted with a combination of clock and pdf display.

Thank you, that is useful, although odd.

I’ll feedback to the development team and see what we can find.