Xibo 1.8.x Linux server reboot doesn't load CMS website

I have a weird issue that I can workaround but would like a better solution if possible. We have Xibo 1.8.7 running on a Turnkey LAMP server on VM (local). It’s worked fine for a couple years, and I upgraded from 1.8.2 to 1.8.7 last month. That went fine, and sometimes rebooting the LAMP server goes fine…but today I rebooted the VM LAMP server and even though it appears Docker/CMS loaded on the server, I can’t access the web GUI (http://xibo.mydomain.com). No SSL, it’s all internal.

When the Linux server reloads, I show the normal 3 IP addresses for br-34128c27d982, docker0, and eth0. I’ve tried docker-compose stop and docker-compose start; all looks good:
root@lamp /home/xibo-docker# docker-compose stop
Stopping xibodocker_cms-web_1 … done
Stopping xibodocker_cms-xmr_1 … done
Stopping xibodocker_cms-db_1 … done
root@lamp /home/xibo-docker# docker-compose start
Starting cms-db … done
Starting cms-xmr … done
Starting cms-web … done

But I still can’t access the web GUI on port 80 like normal, unless I revert to my last VM snapshot and reload it. I don’t want to do that if I don’t have to. Would a docker-compose down/docker-compose up fix it, do you think?

FYI on versions:
docker-compose version 1.12.0, build b31ff33
docker-py version: 2.2.1
CPython version: 2.7.13
OpenSSL version: OpenSSL 1.0.1t 3 May 2016

NM - I went ahead and just backed up the server then did an upgrade from 1.8.7 to 1.8.9, since I planned to do that anyway, and now everything works great, including the web GUI on port 80.