Xibo 1.8 Installing with Docker on Windows, can't get to http://localhost


#1

Hello Good Community!

I have an important question and i hope anyone can help me with this problem.
I really need to install Xibo 1.8 with XMR but i dont know how… I already installed xibo 1.7.9 and it works fine but the 1.8 install isnt that easy like the 1.7.9. I red that the “docker” install version already got XMR configured. But how can i install it with Docker?
Could anyone give me an Step-by-Step Instruction for the Xibo 1.8 Install?
Because i want to use the API from 1.8

Hope anyone can help me!


#2

Hi together,
I have the same Problem with Docker. I wanna testing the 1.8 rc, but with Dockerinstallation on my Windows 7 Maschine i have a big Problem. Yesterday i try 4-5 hours and today 2-3 houes of reading Installation instructions, copy files, try with the Powershell and so on… but i bring nothing to work. I feel realy desperated…

Is there a possibillity to install like the "old"way? I only need files and a SQL dump. I dont need any Containerformat or similar with empeddet Webserver or SQL-Server…

I hope it is possible finding a easyer way for an Installation.

I wish you all the best in 2017.

In german: Guten Rutsch :wink:

Torsten


#3

Unfortunately with a more complex and secure application comes a more complex installation - there is no way we can make the install as easy as it was before, while still maintaining the extra features and security.

Docker will be our installation choice in the future and will be the way we try to move forwards.

Installing Docker is fairly straightforward and there are detailed guides for doing so here: https://docs.docker.com/engine/installation/ - choosing the Docker ToolBox for windows would be best: https://docs.docker.com/engine/installation/windows/#/docker-toolbox

Then you can follow our installation guide here: http://xibo.org.uk/manual-tempel/en/install_docker.html

If you are having problems please describe what you’ve done so far and where you are stuck, we will assist you and use the experience to improve our documentation in the future.


#4

Hi dan

Yehhha, with the Docker Toolbox i see a light on the end of a dark tunnel :wink:
I install the Toolbox on my Win10 Notebook (i hook everything on the Setup on). That works good.
Then i unzip the xibo-docker-master.zip to an directory of my choice.
After that i start the Docker Quickstartterminal. I change to the Folder where i unzip the xibo-docker-master and enter in the termin ./launch bootstrap. I edit the launcher.env of my choice and save. Then i write ./laucher bootstrap again und in the Windows i see somethin is downloading. it takes a couple of minutes bevor it is done. Everything look fine at this point. In the last row its displayed: CMS ist starting, It my takes a few moments to fully running.

Ok i wait… Nothing is happend on my Browser. ok i do ./laucher start. Nothing happend. Ok i do a destroy an a bootstrap again, Changing somthing in the launer.env. bootstrap again. Nothing happend…

On my webbrowser i try localhost or 127.0.0.1. I change port from 80 to 81 and try again, nothing is shown…

Can you help me again, i think im a couple of steps away from the success ?

Thank you for your support

Torsten


#5

What do you have in your launcher.env file?

I wonder if you’ve got another web server running on your laptop, maybe after your failed tests from before, which is already using the standard web server port 80. This is then blocking the Xibo Web container from starting.

To quickly test this out, I would suggest changing your launcher.env file to use a different web server port. If this works, then you know you already have something using the default port 80.


#6

hi
today i try again and it works. On windows i use 192.168.99.100 (IP-Adress from the Dockercontainer, displayed at the start of Docker toolbox) and not localhost or 127.0.0.1.
Pleas write that as info in the Installationinstructions.

Greetings Torsten


#7

@alex - is it expected that the Docker Container gets its own public IP? I thought it would only proxy from localhost?


#8

The container -> docker host is it’s own private network, which docker manages and exposes ports as required.

On Windows, docker itself runs on a VM inside virtualbox, which I think should be in bridged mode so that the VM running the docker host has a LAN IP address.


#9

So on Linux/Mac you’d expect to access the final site at localhost:8080 but on windows you’d need container_ip:80 ? So why do we port map on windows?

I guess I am a little surprised the VM is in bridged mode, as I expected it to be on a private network with the host port 8080 mapped to the private network port 80


#10

Because on Linux, localhost and the box running Docker are one in the same.

On Windows, localhost is the Windows server running VirtualBox, in which is a Linux server, which runs Docker. Docker controls which ports running inside containers on that VM are exposed to the VM’s IP.

If the interface isn’t bridged, then there’s no way for the ports exposed from the Docker container to the Docker VM running inside VirtualBox to be available on the LAN attached to “localhost”.

The reason Docker port maps is because the VM is running many containers, and so you need to specify which ports of those should be available - in exactly the same way as you do for Linux.

If you ran Docker inside a VM on a Linux box, you’d have exactly the same arrangement. Windows isn’t capable of running containers directly. They require a Linux install to do it - either running in VirtualBox or HyperV


#11

Thanks Alex, I completely understand.

The IP mentioned by the OP is the Docker Host VM IP address, not the container IP address

I’ve submitted an issue to add some flesh to the bone for the Docker Docs regarding windows.


#12

I have been spending hours trying to figure this out. I really have no experience with the terminal based installlation and find it extremely confusing. I curently run xibo on my server but really want to upgrade to make use of the new features. But as I see it upgrading to 1.8 to very confusing using the docker system and there is little to no documentation to help with the Xibo install for Docker. Will there be any updated documentation because as of now the instructions seem to be around 3 lines.


#13

It should be straight-forward, but if we’ve missed something with the documentation we’re happy to add it. If you are coming from 1.7 you will want to follow install docker

http://xibo.org.uk/manual-tempel/en/install_docker.html

and then follow the “switching to docker” instructions:

http://xibo.org.uk/manual-tempel/en/upgrade.html#switching_to_docker

If you are already running a web server (which it sounds like you might be), then you should either remove it completely, or set Xibo to use a different port.


#14

Similar problem here using Docker for Windows … I’ve gone through the installation documentation successfully but browsing to http://localhost is not working (can’t reach the page).

I did have problems initially and may have stuffed up a few things i.e. installed Docker Toolbox (and then later installed Docker Windows), had an IIS instance running (removed now) … I’m wondering whether something could be messed up …

I tried changing the port in the cms_custom ports.yml file like so:


cms-web:

    image: xibosignage/xibo-cms:release-1.8.9

    volumes:

        - "./shared/cms/custom:/var/www/cms/custom"

        - "./shared/backup:/var/www/backup"

        - "./shared/cms/web/theme/custom:/var/www/cms/web/theme/custom"

        - "./shared/cms/library:/var/www/cms/library"

        - "./shared/cms/web/userscripts:/var/www/cms/web/userscripts"

    restart: always

    links:

        - cms-db:mysql

        - cms-xmr:50001

    environment:

        - XMR_HOST=cms-xmr

    env_file: config.env

    ports:

        - "8080:80"

    mem_limit: 1g

Then I did a docker-compose down + deleted the shared folder under C:\Xibo and then ran docker-compose up -d

Still no luck? Am I doing something wrong?


#15

After pulling my hair out all weekend I decided to sleep on it and come back in the morning … I must’ve had a dream of enlightenment and this morning tried to add http://localhost to the local intranet zone in IE, and also in the bypass proxy list … this seems to have done the trick now :slight_smile: