Xibo 1.7.4 Settings not Saving [UPDATED]

Hi all,

I’ve just upgraded from Xibo 1.4.2 to 1.7.4 and I’m having one substantial problem - If I try to save any of the settings in Administration > Settings using the big green save button, nothing happens. When I say nothing happens, I mean that literally - no error, no confirmation, and no changes to the settings are saved. I’ve tried Chrome, Firefox and IE. I’ve also had someone else try it on another PC. No luck.

I’m able to make other changes in the CMS, and they save perfectly fine. For example, I can add and modify displays, change layouts and modify users.

I’d love some help with this please. This is a non-production system, but I’m trialling it for a production system and I think this is the only problem I have, other than this the upgrade has gone fine. I did try giving Xibo the root database user, in case something was wrong with the permissions for my xibo database user, but that hasn’t helped.

Finally, my system is running, Centos 6.7, Apache 2.2.15-47, PHP 5.3.3-46 and Mysql 5.1.73-5.


P.S. Love your work. Xibo is a great system.


I’ve found the problem. When I upgraded to the new version, I did the upgrade on a new server running a different distro. The Xibo Library folder location in the new version was invalid due to the new distro’s different directory structure. Problem is, you can’t change the location of the library to the correct location if it wont let you save this in Settings - a Catch-22. So I symlinked it which brought the Save button back to life, then changed it to the actual location.

First up clear your browser cache, close the browser and then open it and log in to Xibo. Sometimes some old cached Javascript will prevent things like that working.

Thanks for the reply, but no luck with that.

I tried clearing the cache in two browsers and tried on a machine that couldn’t have had anything cached (it was a brand new Windows build). Still the same behaviour.

More thoughts? Could this be a bug maybe?

I don’t think so. We have thousands of 1.7.4 installs. If there were a general problem saving settings we would know about it by now.

Is anything logged?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.