Why is not the height of the iframe scaled correctly in xibo?

Hello everybody, please excuse my bad English. I have a question. I use xibo as an ad for our football club.:soccer: Here I have the chance to create a table widget. The widget looks e.g. like this:

What does it look like on the screen? I have many layouts that are not previewed correctly but show correctly on the screen. There are a number of reasons for that.

I looked at the page you are using in the IFrame, it has a lot going on and it could be possible that the page is trying to adjust the way it displays according to what it detects.

In addition I also see that you are applying your own class to the iFrame. Without seeing all of the code involved, it is a little hard to say what the problem is.

Hi, you can see two screens…one is without scallieren and one is with scalieren…but the whole table is not screen on the high 1080px. Do you know what i mean… in the iframe i set the high on 1080px but in xibo it will not screen…

Can you say me the mistake?


Is the display profile assigned to the screen in xibo 1080p format?

When I created the layout, I chose landscape 1080p. Although I’m not an expert on Xibo, I know a little bit about it.

It’s just that the created iframe that is already a right size just is not taken over by Xibo in height.

I always create the layout in 16: 9 so 1920x1080px, since the monitors are in 16: 9 format

Here, the creators of Xibo should think about it and check it in their html scripts.

If you have any questions, please contact us. that would be great if we could solve the problem.

I think adding your own iframe and then trying to scale that yourself, and then applying Xibo’s scaling is causing issues.

Instead, just use the webpage widget, and the URL from your iframe - ie


Hello Alex,

thanks for your answer.

I think so too that this is the problem…

Please, can you sy me where i must put it in?? In Webpage oder Embedded?? I mean your URL

Use the Webpage widget as I suggested in my previous reply.

You’ll have to try the various settings, but I’d start with Open Natively. It very likely won’t look right in the Preview as scaling external content unlikely to go as expected. See what it looks like on the Player, and adjust accordingly.

Hi Alex,

i think you are the BEST :slight_smile:

So if I just enter the URL as you wrote and it works!

When I copy your URL link and then set to native and o.k. nothing is displayed. If I place in manual position then I can play with the%. You know what I mean

1 Like