WebOS fails to load content after CMS upgrade to 4.0.1

We have an environment with both WebOS agents and Windows. The Windows agents work without any problems. But the WebOS agents don’t load any content. Only the content in the cache is displayed if that is available. Everything was working fine before upgrading to 4.0.1 we have already tried upgrading to 4.0.2 but still the same issue.

The only error message that I can find is on the WebOS Info screen within WebOS:
Failed to download file with error code 22 / HTTP error code : 404

I don’t see the error message on the server"

Server specifications:
Xibo CMS: 4.0.2
Linux: CentOS 7
PHP: 8.3
MariaDB: 10.11

WebOS version: 6.0.0
Code version: 308
Model: 49UH5J-HP

Would it be possible to upgrade your CMS to 4.0.3 to see if that helps? There were several issues downloading content which might be to blame here.

Is your CMS environment configured for HTTP send file?

As these are webOS players you could open a ticket for help.

Thanks!

We just upgraded to 4.0.3 this solved the problem after we have turned off the monitors and after the application started pressing one time on the “Connect CMS” button in WebOS. Without pressing Connect CMS it would not connect.

Thanks for the feedback - it’s good to hear that 4.0.3 solved the problem and we will investigate why a manual reconnect was necessary.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.