Weather Forecast No Show Turkish Language

Names days in case the weather is not what I need to do Turkish language does not change even though I change the language from regional settings

As I already told you, in most cases it should be like this:

Change the CMS language to Turkish (settings->regional, language -> tr)
In forecast io item you can also set the language to Turkish, now that will work on all templates, but 5 days, one in a big circle will still not work correctly.

To make this template work as well you will need to:
CMS settings -> regional
date format: YYYY-MM-dd HH:mm:ss
tick the “Show international dates?”

Now on the forecast item with the ‘5 days, current in a big circle’ template
you will want to tick 'override the template’
find the following lines:
<div class="weekday">[time|l]</div>
<div class="weekday-short">[time|D]</div>

and change them to:
<div class="weekday">[time|cccc]</div>
<div class="weekday-short">[time|eee]</div>

This way you will have Turkish days names.

I know it does not work on your CMS quite well, perhaps have a look in logs/report fault page.