User not found in Database after Upgrade and switch to Xibo for Docker

After following the Upgrade and switch to Xibo for Docker install guide including importing the exported database none of the ‘users’ can login.

The original server is running Xibo 1.7.5

If i connect to the cms database using mysql and try to rest the password for the users, e.g. admin, i get Error 1146 (42502): Table ‘cms.admin’ doesn’t exist.

Using PHPmyadmin to look at the database and compare with the database on the original server i can see that several tables are missing (everything after ‘oauth_client_scopes’ missing) and therefore the User table is missing.

No matter how many time i export/import the datebase i get the same result. I am using PHP myadmin to export the database as on the original server when i try to run Mysql in powershell it comes up as unrecognized command.

Also after i run ‘docker-compose up -d’ the xibo-docker-238_cms-db_1 container keeps restarting for a while before it will stay ‘running’.

The only login that works at all is ‘cms’ using the database password, however this opens the web interface with only the Dashboard and a message saying ‘error Sorry the form has expire. Please Refresh’. Refreshing doesn’t change anything.

Can someone help me get this sorted out? Thanks

Hi Karlmash, welcome to the Xibo community!

Your message suggests that you are upgrading your 1.7.5 CMS straight to 2.3.8, which is not recommended. Could you try upgrading your CMS in the following order. I have included links to the files you will require for each release.

Please make sure you create a backup of your media library and database between each upgrade step and test each upgrade to make sure it was successful before you proceed to the next version in the below list. You must also allow your XTR tasks to run and complete before proceeding to the next version of Xibo CMS

Step 1: Upgrade to 1.7.10:

Step 2: Upgrade and migrate to Docker 1.8.13:

Step 2: Docker upgrade to 2.3.8:

Here is a link to our docker upgrade guide, which you can use for the upgrade from 1.8.13 to 2.3.8:

https://xibo.org.uk/docs/setup/upgrade-xibo-for-docker-install

Many Thanks.

1 Like

Hi DanBW,

Fully upgraded and running ok now after following your instructions.

Many Thanks

The Xibo Community site uses cookies. What are cookies?