Upgrade to Xibo Docker Fails

CMS Version

Upgrading from custom install of 1.7.4 to xibo-docker-2.3.10

Installation Method

Docker

Operating System

CentOS Linux 8.3

Issue

Hi all,

I’m having trouble with upgrading from my traditional install running 1.7.x to a Docker installation. I’ve followed the guides on docker setup and the Xibo upgrade process very carefull (I’m new to docker, so I’ve been taking it slow) but it seems to not complete the upgrade. The upgrade process gets underway, but never finishes. The webserver shows the following forever. I waited 24 hours but to no avail. I also tried taking it down and back up again using docker-compose -f docker-compose.yml down and up - I also tried deleting the whole db directory and starting it again, but that just did the same thing.

I’ve attached the output of docker-compose -f docker-compose.yml logs cms-web - so hoping you can provide some help and advice here.

xibo-log.pdf (75.4 KB)

I hope I’ve covered everything but if you need any more info, please ask.

Many thanks.

I would first upgrade the install to 1.7.10 (on your original system), then upgrade to 1.8.13 with Docker, and then to 2.3.

You can’t go directly from 1.7 to 2.3 in one step.

Thanks Alex, I’ll do that!

Cheers!

Hi again,

I successfully got our server to v1.8.13 with docker, as suggested (which went smoothly) . The upgrade to v2.3 hasn’t been successful though. It’s stuck at the “The CMS is temporarily off-line as an upgrade is in progress” page again. There are a few errors in the logs, which I’ve attached again but I’m not sure if they’re relevant - hoping you can help or suggest more troubleshooting steps.

cms.pdf (79.8 KB)

Thanks.

It looks like a table has been partly upgraded already. Is this log from the first time you tried to upgrade the database from 1.8 to v2?

If I send you a transfer link, are you able to send me an export of the database and I’ll have a go at upgrading it here for you.

Sure, please go ahead and send the link - I’ll send you an export of the DB.

No, it shouldn’t be from the first upgrade - I blew that install away and started again.

Many thanks.

Issue was because of the MySQL 5.7 update. The following would have worked:

1.7.4 -> 1.7.10
1.7.10 -> 1.8.13
1.8.13 -> 2.3.9
2.3.9 -> 2.3.10

or alternatively remaining on MySQL 5.6 and going 1.8.13 -> 2.3.10, and then converting to MySQL 5.7 (running mysql_upgrade as required).

…and thanks to Alex’s help we now have a fully upgraded Xibo install running on Docker.

Thanks for your help and assistance - and for identifying this bug.

L8r.

1 Like
The Xibo Community site uses cookies. What are cookies?