Unable to send two factor code to

I have Configuration problem. “Unable to send two factor code to”. How do resolve this Error?

It depends how you’ve installed the CMS, but assuming you’re using Docker then you need to setup the correct details for your email server in the config.env file, and then down/up the containers to apply those settings.

If you have a custom install, then you need to check that you’ve configured PHP and a mail relay to enable PHP to send email via your server.

Hi Alex

i installed latest docker version
i filled config.env with my gmail and dw/up docker compose but still not work
i want to know what should i fill CMS_SERVER_NAME in config.env ?

CMS_SERVER_NAME isn’t related to email configuration.

We provide all the correct defaults for GMail. All you need to do is fill in your correct email address and password. As noted, you also need to ensure you enable support for less secure apps in GMail, and if you have 2FA turned on use an App password instead of your regular login password.

Hi Alex Thanks for reply

i completely did TFA and every thing is alright
i generated app password and used it

CMS_SERVER_NAME was a question unrelated to gmail configuration but because of saw it in config file i’m confused how should i fill that for better server configuration
is it hostname or something else?
can you say an example replacement for default value

In most cases it’s unnecessary to set it, but if you want to set it, it should be set to the hostname and domain of your server as you will access it from a browser, so for example if you’d access the cms as https://cms.example.org, you would set CMS_SERVER_NAME to cms.example.org

hostname is changeable in the server panel for example my hostname is xibo and it’s not address just a name

and my site address is test.com

so CMS_SERVER_NAME should be test.com ?

The Xibo Community site uses cookies. What are cookies?