Unable to load CMS


#1

Hello all,

entirely new to Xibo and I’m having difficulties getting it to work. When I go to the http://localhost address I just get ‘Page Cannot Be Displayed’. I’m running Windows 10 Pro x64.

I’ve tried multiple alterations to my config.env file (making sure to run docker-compose down, then delete the shared directory, then docker-compose up -d each time I edit it) but I can’t seem to get it to run.

The latest thing I’ve tried is solely to add the MYSQL password (generated by the link in the config file) and then save the config without bothering to edit any of the email settings - but I still can’t get it to work. I’ve added the firewall inbound rules and even tried disabling the firewall entirely but no joy. I’m not altering anything such as ports, I’m leaving everything as default. No need for SSL.

Can anyone point out where I might be going wrong, please?

Many thanks.

EDIT: I should probably say that when I enter no password for the MYSQL section, I get the error message that others have received saying “Fatal Error - sorry this shouldn’t happen. SQLSTATE[HY000] [1045] Access denied for user ‘cms’@‘172.18.0.4’ (using password: NO)”.


#2

I’m actually have this issue as well. I would love if someone could assist with this.


#3

Well update: I was able to finally get it loaded!

So I keep the original settings

And did

docker-compose down

delete the shared directory
correct config.env with a suitable password for MYSQL_PASSWORD (no special character)

docker-compose up -d

i also ran ‘docker ps’ after a few minutes but after doing some research it looks like it takes some time to actually start up.

So I had to wait almost 20 minutes to be able to access the screen.


#4

Can you confirm whether you are receiving any errors after the docker-compose up -d command has run? If you are receiving errors, please provide screenshots so that I can look into this further. Please also confirm which version of Docker (Docker for Windows or Toolbox) and the CMS you are installing.

You may find that the CMS takes a short time to finish setting up after the command is run. If you are not receiving any errors after the up -d command, I would recommend giving the CMS 5 minutes and trying again to see if it is now loading.

Many Thanks.


#5

Hello!

No, there were no errors, but I have an update - mine is working also!

So it looks as if Setienne’s last line “I had to wait almost 20 minutes to be able to access the screen.” is relevant to me. It didn’t say anywhere in the instructions that it took time for the system to go live. It took around 15-20 minutes for the site to actually start working after running the docker-compose up -d command.

Thank you both for your responses!


#6

I’m glad the issue is resolved. I appreciate your feedback about the manual not mentioning the potential delay when running the docker-compose up -d command, I will feed this back to the relevant department.

Many Thanks.