Unable to install

Hoping someone can help…
I have installed a new virtualmin server with apache & php7 etc. I’ve followed the install instructions with the latest xibo 1.8.10 but have hit a brick wall when first visiting the site to initiate the install. At first I just got a blank page with no errors, so I followed the instruction to turn on error display and now i see this:

Fatal error: Uncaught Error: Call to undefined function __() in /home/xibo/public_html/cache/74/741ae8f013602cd72c8694605adc40a8940133c949933fdc643a35e1dc9c1602.php:70 Stack trace: #0 /home/xibo/public_html/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_d792bf4a7414a290d55b361602fc80615989d43095f99eb851a076cfde4afe71->doDisplay(Array, Array) #1 /home/xibo/public_html/vendor/twig/twig/lib/Twig/Template.php(403): Twig_Template->displayWithErrorHandling(Array, Array) #2 /home/xibo/public_html/cache/54/547fef22068d4f39a6bc142e77018efba13b4ce2e32560953a03aa95f1e7f949.php(28): Twig_Template->display(Array, Array) #3 /home/xibo/public_html/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_f31cb4b51d98037fb94b2662c76b496d426e854c0724457411506fba787a736f->doDisplay(Array, Array) #4 /home/xibo/public_html/vendor/twig/twig/lib/Twig/Template.php(403): Twig_Template->displayWithErrorHandling(Array, Array) #5 /home/xibo/public_html/vendor/twig/twig/lib/Twig/Template.php(411): Twig_Template->display(Array) #6 /hom in /home/xibo/public_html/cache/74/741ae8f013602cd72c8694605adc40a8940133c949933fdc643a35e1dc9c1602.php on line 70

Would I be right in guessing it’s a missing php function that i’ve omitted to install?
Can anyone point me in the right direction, I really need to upgrade from my old 1.7.9 as any uploads are being blocked by our new intrusion prevention system on our Unifi gateway.
Thanks for any help.

Please cancel that - I tried 1.8.9 and that worked fine. Guess there’s still some issues with 1.8.10 that need ironing out.

If you had a blank page it might be this bug - https://github.com/xibosignage/xibo/issues/1578
the fix will be in 1.8.11 release, you can also apply that manually or use 1.8.9 and wait for the 1.8.11 release iof you prefer.