Unable to connect to the remote server....player to cms

While testing at office everything works great and connects fine. I move all hardware to different location and player can not connect to cms.

Player windows10.
ver 1.8.3

CMS windows10
ver 1.8.3
docker toolbox.

All firewalls are off on both devices.
What else could it be?
Any advice is appreciated.

When you move the equipment, is your server getting a different IP address than in your test environment? If so, you’d need to update the CMS address in the player to match the server IP.

Docker toolbox will use docker toolbox vm IP address not the device’s IP address.

You can get that by running docker-machine ip from the Docker Toolbox Quickstart Terminal and see if you get different VM IP in the new location, if you do, then all you’d need to do is adjust that in player settings as well.

Thanks for the advice.
After moving to the new location the server was getting a new address I changed the CMS address in the player to match the server and still won’t connect.

I also tried the docker toolbox vm IP address and still won’t connect.

After further investigating the location they have a Sonicwall firewall apppliance. Could this be blocking the CMS and player from connecting to each other?

It could be, might be worth investigating that and white listing CMS address on 80/443/9505 ports (assuming default ports are in use).

If you get the docker toolbox vm ip and navigate to that address, does it show you CMS page?

If you do
docker ps -a
does that show all containers running?

I’m not able to connect to the Sonicwall as I’m not at the location, but I can teamviewer into the CMS and Player to test. Until I can get back to location and whitelist the CMS address.

I am not able to view the CMS page from the player. I can view the CMS page with ‘localhost’ from the CMS.

$ docker ps -a
9a1e85c88644 xibosignage/xibo-cms:release_1.8.3 “/entrypoint.sh” 3 hours ago Up 3 hours>80/tcp computer_cms-web_1
2632411fac5a xibosignage/xibo-xmr:release_1.8.3 “/entrypoint.sh” 2 months ago Up 19 hours>9505/tcp, 50001/tcp computer_cms-xmr_1
dcbe097cf997 mysql:5.6 “docker-entrypoint…” 2 months ago Up 19 hours 3306/tcp computer_cms-db_1

UPDATE: Problem is solved. It was the Sonicwall firewall appliance. After I white listed the cms and player. Everything works great. Thanks for the help and advise.