Twitter Metro - 1.8.2

Has anyone managed to set up and use the Twitter meter?
When I try to include the widget in the region’s timeline I get error:

Unexpected Error, please contact support.

In PHP LOG or CMS nothing appears, neither in debug mode …

Can someone give me an idea of what it can be?

It should be using the same API key as ‘normal’ twitter widget, if twitter widget works, then twitter metro should work as well.

I don’t think we had any problems with this module, perhaps try to verify all modules, make sure twitter is correctly configured and try again.

If the CMS is in debugging / test mode, it generate produce logs about such error - make sure the duration back on Log page isn’t too low or that you don’t use PAGE/Function filters that would not match the error you’re looking for.

Hello Peter,

I could only get the log data from the Log table.
I could not make the twitter metro work. Twitter is working normally.
Any idea what that might be?

An exception has been thrown during the rendering of a template (“Unknown class Xibo\Widget\Twitter”).#0 \cache\29\29fd50229ed327912b60fa61ba591f1dbf5045c07f1e29a67d4dc596569293c7.php(75): Twig_Template->displayBlock(‘formHtml’, Array, Array)
#1 \vendor\twig\twig\lib\Twig\Template.php(215): __TwigTemplate_cd9eb3574de33b2714d31a1b6f74ff9dc7fbebe0230122774ef2384bc4e4dfc4->block___internal_dc1b481d0c4b922145ef8da67c35f6967e53f2d677184fdb85a3a7655aa1ec61(Array, Array)
#2 \vendor\twig\twig\lib\Twig\Template.php(279): Twig_Template->displayBlock(’__internal_dc1b…’, Array, Array, true)
#3 \cache\29\29fd50229ed327912b60fa61ba591f1dbf5045c07f1e29a67d4dc596569293c7.php(37): Twig_Template->renderBlock(’__internal_dc1b…’, Array, Array)
#4 \vendor\twig\twig\lib\Twig\Template.php(438): __TwigTemplate_cd9eb3574de33b2714d31a1b6f74ff9dc7fbebe0230122774ef2384bc4e4dfc4->doDisplay(Array, Array)
#5 \vendor\twig\twig\lib\Twig\Template.php(406): Twig_Template->displayWithErrorHandling(Array, Array)
#6 \cache\ff\ffca4f79300a47602de7728a998ad7de7f9e4fe605385c8e6ff8cf6ba85972cf.php(32): Twig_Template->display(Array, Array)
#7 \vendor\twig\twig\lib\Twig\Template.php(438): __TwigTemplate_92be8412db0edfd2d37f7f27c4eed3ebc2bbd704a22180cd81ca121be8ce62b3->doDisplay(Array, Array)
#8 \vendor\twig\twig\lib\Twig\Template.php(406): Twig_Template->displayWithErrorHandling(Array, Array)
#9 \vendor\twig\twig\lib\Twig\Template.php(417): Twig_Template->display(Array)
#10 \vendor\slim\views\Twig.php(92): Twig_Template->render(Array)
#11 \lib\Controller\Base.php(410): Slim\Views\Twig->render(‘twittermetro-fo…’, Array)
#12 \lib\Controller\Base.php(323): Xibo\Controller\Base->renderTwigAjaxReturn(Array, Object(RKA\Slim), Object(Xibo\Helper\ApplicationState))
#13 \lib\Middleware\State.php(113): Xibo\Controller\Base->render()
#14 [internal function]: Xibo\Middleware\State->Xibo\Middleware{closure}()
#15 \vendor\slim\slim\Slim\Slim.php(1210): call_user_func_array(Object(Closure), Array)
#16 \vendor\slim\slim\Slim\Slim.php(1358): Slim\Slim->applyHook(‘slim.after.disp…’)
#17 \vendor\slim\slim\Slim\Middleware\Flash.php(85): Slim\Slim->call()
#18 \vendor\slim\slim\Slim\Middleware\MethodOverride.php(92): Slim\Middleware\Flash->call()
#19 \lib\Middleware\Actions.php(142): Slim\Middleware\MethodOverride->call()
#20 \lib\Middleware\Theme.php(35): Xibo\Middleware\Actions->call()
#21 \lib\Middleware\WebAuthentication.php(132): Xibo\Middleware\Theme->call()
#22 \lib\Middleware\CsrfGuard.php(62): Xibo\Middleware\WebAuthentication->call()
#23 \lib\Middleware\State.php(117): Xibo\Middleware\CsrfGuard->call()
#24 \lib\Middleware\Storage.php(47): Xibo\Middleware\State->call()
#25 \lib\Middleware\Xmr.php(36): Xibo\Middleware\Storage->call()
#26 \vendor\slim\slim\Slim\Slim.php(1302): Xibo\Middleware\Xmr->call()
#27 \web\index.php(124): Slim\Slim->run()
#28 {main}

An exception has been thrown during the rendering of a template (“Unknown class Xibo\Widget\Twitter”). Exception Type: Twig_Error_Runtime

I’m not sure why would it have issues rendering the template - is that using one of the pre-defined templates (is the issue occurring on each one of them?) or did you modify the template?

Hi Peter,

I get this error by selecting the Twitter Metro widget to include in the region’s timeline.
I can not even get the template selection.

The Twitter widget is working perfectly, I just can not include the Metro Twitter widget on the timeline.

I did not make any changes to code or templates. If you wish I can email you the data to access the CMS.

Hi Peter,

I’m not sure what the problem was.
Performing the installation verification of the modules did not work.
I have deleted in the modules table the register for the module Twitter and Metro Twitter, in this way both appeared again for installation.
Performing this procedure worked.

What motivated the bug I do not know, I’m just using the CMS without any customization 1.8.2 with upgrade from 1.7.9

Interesting, presumably you did the same thing after upgrade, as from memory twitter/twitter metro modules are not installed by default - although you probably had the twitter module installed in 1.7.9 so after upgrade you just installed the metro one, I wonder if that caused some sort of mismatch along the way.

It’s hard to say why it didn’t work / installed correctly, @dan any ideas based on Laercio’s log?

In any case I’m glad that re-installing those two modules solved the problem.

Perhaps the SQL upgrade step which inserts those two modules didn’t work correctly. I don’t think its a general issue as we’ve run lots of upgrades with success.

The modules table contains a class name, which is used to load the Module handling class - it seems that could not be found Xibo\Widget\Twitter.