Trying to upgrade to 1.8 Not getting past PHP Version

Getting an x for PHP version. Running on Microsoft Azure, have PHP 7.0.15 running, everything else passes the check.

What’s the fix on getting this to support PHP 7?

Thanks.

PHP7 isn’t supported at this time since some of the libraries the CMS uses aren’t compatible with it yet.

You will need to use an older version of PHP (5.6) or move to Docker as we suggest, in which case all of the dependencies are taken care of for you.

Any ETA on PHP 7 support so that us cool kids that live on the newest stuff will have this working?

I don’t have a date to share with you no.

It will depend on the underlying libraries making updates as I understand it.

I would also be interested in seeing Xibo run on PHP 7 so I can install Xibo on my IIS 10 server. Specifically so I can use the most recent ZMQ plugin and library file. I’m currently running 1.1.2 beta because these isn’t a PHP 5.6 version of php-zmq 1.1.3 available at https://pecl.php.net/package/zmq