Trying to upgrade from 1.7.7 to 1.8.2

I replace my document root entirely, I’m using cms, and not docker, because docker isnt possible in my environment as I run a hyper-v machine, and docker will simply not work correctly. And I copy the files, the settings.php and when I login it prompts for upgrade. When I click start, it just spins on step one alter the log table and never progresses and eventually logs me out. What am I doing wrong? Thanks!

I have a working 1.7.9 install on Win 10 - http://localhost/xibo. I created a new folder http://localhost/xibo-1.8 but all Apache will give me is the directory listing? I am using XAMPP 5.6.32 (latest). What am I missing?

Apache gives directory listing when your website file structure is in the wrong folder. (meaning, the folder that apache is looking in for a index.php or index.html doesn’t have either of those files) In the case of Xibo, it should be something like, Htdocs\web. Or if you have it in a sub folder inside of your Htdocs folder, htdocs\xibo\web.

I solved my own issue here, For me the log file in mysql was up to ~48,000,000 entries, which was far too many for xibo to process. I truncated (deleted the contents but not the table) the log table in my Xibo database, and the upgrade went perfect.

1 Like

Please ensure you setup XTR in that case on your upgraded install, to prevent that buildup of logs. You should have been running maintenance on your 1.7 install for the same reason.