Translation missing for Finance CMS 1.7.5 Module

  • An optional name for this media

As far as I’m aware it just needs to be translated over in Launchpad and then it will be automatically included in future releases.

Alex, I tried to make the translation yesterday. Why have not found I opened the topic.

https://translations.launchpad.net/xibo/github/+pots/default/pt_BR/+translate?batch=10&show=all&search=An+optional+name+for+this+media

So it’s definitely translatable.

It looks like maybe the updated translation template didn’t make it over to Launchpad yet. I shall ask @dan

I spoke with @dan. Because of the way translations get in to Launchpad now that we don’t use it for code development unfortunately that string won’t be available to translate without manual intervention.

We’ve updated the template and the string is there to translate now:
https://translations.launchpad.net/xibo/1.7/+pots/default/pt_BR/+translate?batch=10&show=all&search=An+optional+name+for+this+media

Note that because it’s 1.7 series you need to be looking at 1.7 series translations not 1.8

@alex

Alex, thank you.

If the interest, I can produce a list of all terms not identified in translations.launchpad.

So could include that we may translate manually.

What do you think?

All strings which are translatable in 1.7.5 should now be available in Launchpad. There shouldn’t be a need to produce a list.

1.8 has a completely reworked UI and the translations are different so I don’t think focusing any significant effort on 1.7 is worthwhile as there will be no future benefit.

Okay Alex,

Translations of 1.8 are available in https://translations.launchpad.net/xibo/github/+pots/default/pt_BR/+translate ?

If it is, I can ask my team to start the translation.
All the terms have changed or only a few have been included?

So yeah translations for 1.8 are in the github branch. Anything that’s common with 1.7 will have been translated already in there. Anything that’s new will be available to translate.

Each time Dan pushes new translation templates in to Github, Launchpad will update a few hours later and those new strings will be ready to translate.

Your team’s help in getting the pt_BR translation up to speed would be greatly appreciated.

Best wishes

Alex

OK, let’s get translations PT BR

@dan

Version 1.8 could not do translations appear in CMS. This part is not yet ready?

I expected them to work, but I can see that they don’t… I think I know why and am looking into it - further reading here: https://github.com/twigphp/Twig-extensions/issues/152


It can be solved by changing: Twig_Extensions_Node_Trans Line 41 to $function = null === $this->getNode('plural') ? '__' : 'n__';