Stuck on splash screen - Linux client 1.8-R3

Hello,

I’ve install Xibo linux client 1.8-R3 through “snap” on Ubuntu 18.04.3 LTS.

I’ve a working client under Windows, so layout is ok. I’ve correctly set the Display profile to linux for the player. Layout is very light (6 Mo).

When i launch xibo-player option, i fill all option and it say : Display is active and ready to start.
When i click on “Launch client” xibo player option close and nothing happen.
When i start xibo-player it start but stay on the splash screen.

I don’t find the log for the linux client.

I’ve see that files in the local folder of Ubuntu are not exceed 284 bytes (.otf, .ttf, .mp4, .jpg, .js, .css).
I’ve set chmod 777 on that folder and files but same issue.

Do you have any idea ? I don’t know where to find more log or info

Regards

1 Like

Thank you for your message and welcome to the Community. Can you confirm what version of Xibo CMS you are using?

It’s possible that the Player is showing the Splash screen as it has not yet downloaded the required files to display the Layout you have scheduled, or the Default Layout you have set. If you have not scheduled a Layout or set a Default Layout, then it is expected that the Player will simply show the Splash Screen.

A good way to locate a Display is to open the Xibo Player Options again on your Ubuntu machine and click the Advanced tab. You will see an entry named Display ID. This is the unique identifier for that Player which ensures a new entry is created in your CMS. You could make a note of that ID, return to your CMS Displays menu option and click the button at the end of each entry. Choose the Edit option to open the Edit Display window. If the Display ID matches the Hardware Key for that Display entry, this is the entry for that Player.

Can you provide a screenshot of the entry for the Display? I would be interested to see what the Columns named Status, Authorised and Logged in state.

Many Thanks.

Thanks for your quick reply.

CMS Version is : Version 2.1.0

Splash screen is now display for a lot of time, the strange thing that the files in the local ubuntu client folder are freeze to 284 bytes.

I check the display hardware key like you said and find the correspondant display on the CMS, please find below the screencapture :

Thank you for the screenshot, this is indeed quite unusual. Can you confirm the types of media in your Layout?

When you start the Xibo for Linux Player, you should also have a Terminal open automatically that will log any errors, can you check for this terminal and confirm of you see any errors? Please note that closing the Player can also close the terminal, you may need to hold the Alt button and click the tab key to display the terminal on top of the Player, or alternatively minimise the Player to also reveal it.

Many Thanks.

For media type it’s an mp4 :


For terminal that open in same time with xibo-player i only have :

[18:15:52.176] [009027] [debug]: ScreenSaver is suspended : 1750813557
[18:15:52.176] [009027] [debug]: http://127.0.0.1:9696/

I notice xibo-client will close after a delay but terminal doesn’t log more info than the two line from above.

This is a fresh Ubuntu install. Only install snap and xibo-client.

Thanks a lot for your help

i am also experincing this with the 2.1 CMS + 1.8R3 Client. Some terminal output attached.

also get [SOAP] Stream truncated after a few minutes

Thank you both for the information on the issues you are experiencing. I would be interested in testing your Layouts on my own Xibo for Linux Player to see if I encounter the same issues. If possible, can you provide a download link for the exported Layouts in a Private Message please?

Many Thanks.

Thanks for your support, i just send you a private message with the layout.