startWebServer - cannot start webserver

Hi everyone,
I’m having some issues with Xibo for Android 1.8 R102 and R103. It shows the following error “startWebServer - cannot start webserver: bind failed: EADDRINUSE (Address already in use)” ONLY in portrait orientation. In landscape we don’t have any problem. We already check all the possible causes and suggestions that you tell in other related issues.
This causes that, in layouts with HTML, it restarts and stops showing the content.

Any idea of how it would be possible to fix it?


1 Like

I don’t see how the player orientation may have any impact on that, the error itself means that something else is using the same port as Xibo is trying to use for the local webserver, by default that’s port 9696.

It can be another instance of Xibo player, or other application.

You can try changing this port in CMS and see if it will work better for you, it’s in the Display Settings -> Edit display profile assigned to your device -> Advanced -> Embedded Web Server Port

Hi Peter,
Thanks for answering.
I’ve already tried that, but the error continues. I’ve check all the posible solutions that you mention in other topics. Although it sounds weird, it only happens with the vertical orientation and Android Lollipop.

I found a solution that worked fine for my displays. After days, weeks and months of debugging, I managed to isolate the problem. It looked like this error message came from network errors. When connecting my Xibo-displays to another network (4G-router or my mobile phone) everything worked fine.

The problem network used intelligent Cisco switches. By using: spanning-tree portfast on the Cisco ports that connected the displays, everything worked fine.

It looks like my displays (Philips 55bdl4050d with Android 4.4.4) dind’t want to wait for DHCP or Static IP-connections. When using portfast, everything works faster and my display could connect to Xibo-server.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.