# Setup on Ubunto Docker in subdomain

**URL:** https://community.xibo.org.uk/t/setup-on-ubunto-docker-in-subdomain/17138
**Category:** Get Help
**Created:** [January 8, 2019, 2:58pm UTC](https://community.xibo.org.uk/t/setup-on-ubunto-docker-in-subdomain/17138 "2019-01-08T14:58:44Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Finn\_Larsen](https://community.xibo.org.uk/letter_avatar_proxy/v4/letter/f/e274bd/32.png) [@Finn\_Larsen](https://community.xibo.org.uk/u/Finn_Larsen)
#### Post date: [January 8, 2019, 2:58pm UTC](https://community.xibo.org.uk/t/setup-on-ubunto-docker-in-subdomain/17138/1 "2019-01-08T14:58:44Z")

</div>

Hi

I godt this error

Removing xibo\_cms-web\_1  
xibo\_cms-db\_1 is up-to-date  
xibo\_cms-xmr\_1 is up-to-date  
Recreating 85169ece0c48\_85169ece0c48\_xibo\_cms-web\_1

ERROR: for cms-web Cannot start service cms-web: driver failed programming external connectivity on endpoint xibo\_cms-web\_1 (9f10763ed3da6e870dfd912998b99cbdf0e80a3fe43c431e5601a336ea65b3e4): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use  
ERROR: Encountered errors while bringing up the project.

---

<div class="post-metadata">

### Author: ![DanBW](https://community.xibo.org.uk/user_avatar/community.xibo.org.uk/danbw/32/5608_2.png) [@DanBW](https://community.xibo.org.uk/u/DanBW)
#### Post date: [January 8, 2019, 3:26pm UTC](https://community.xibo.org.uk/t/setup-on-ubunto-docker-in-subdomain/17138/2 "2019-01-08T15:26:42Z")

</div>

Can you confirm if you have any other services using port 80 on your setup? The error suggests that the address the CMS container is trying to use is already in use.

If you are have another service running on port 80, you will need to run either the CMS container or the other service on a different port. I have included a link to our setup guide below, which contains a section on using different ports:

[https://xibo.org.uk/docs/setup/xibo-for-docker-on-linux](https://xibo.org.uk/docs/setup/xibo-for-docker-on-linux)

Many Thanks.

---

<div class="post-metadata">

### Author: ![aponkye](https://community.xibo.org.uk/letter_avatar_proxy/v4/letter/a/ed655f/32.png) [@aponkye](https://community.xibo.org.uk/u/aponkye)
#### Post date: [January 10, 2019, 6:00am UTC](https://community.xibo.org.uk/t/setup-on-ubunto-docker-in-subdomain/17138/3 "2019-01-10T06:00:58Z")

</div>

if that same server is running a web server like apache or nginx, run a command to stop it, then edit your webserver to run on a different port like 8080 then start the webserver and also restart docker

---

<div class="post-metadata">

### Author: ![system](https://community.xibo.org.uk/uploads/default/original/2X/a/a8759c2d8cc561474733895ac75beeb830f5d8ca.png) [@system](https://community.xibo.org.uk/u/system)
#### Post date: [March 4, 2020, 5:12pm UTC](https://community.xibo.org.uk/t/setup-on-ubunto-docker-in-subdomain/17138/4 "2020-03-04T17:12:58Z")

</div>


