Schedule.xml not updating on clients


I’ve set up xibo at my work and I currently have around 12 clients. I am having an issue when changing the content on the screens that I can’t seem to fix…

My current setup is on a windows 2012 server with IIS, and the clients are win7 PCs. I have one scheduled layout, and when changing something I use the “replace” function on the relevant media. What the clients do then, is they download the new file, in this case “62.wmv”. But the schedule.xml in the library stays the same. The client deletes the old 61.wmv and then it is set to play 61.wmv but only has 62. So it plays nothing, and just shows the Xibo splash screen.

Manually changing the xml-file and restarting xibo makes it play the right file. This happens on all the clients. If I delete the schedule.xml file it redownloads it but it still says 61.wmv. XMR is running, as far as I can tell. Running report fault comes up with “All checks pass. Click next to continue”.

Here is a screenshot of a client:

Any ideas on what to do with this issue?

Is that on 1.8.2 CMS and player?

Could you enable auditing on that display, then make the media replace with ‘Update this media in all layouts it is assigned to?’, open the layout in layout designer to make sure the change was applied there.

Then wait for the player to download new file and check if it will report any other errors.

1.8.2 on both CMS and player, yes.

I have enabled auditing on one of the displays, but now it seems like it worked as it should for some reason… Though this has happened before, once before I’ve reuploaded the file a second time and it worked. I will keep the audit on until a new presentation is made for the screen and see how it goes then. For what it’s worth, I always use the “update this media in all layouts” and it does update the layout.

I’ll report back with the audit log when it happens again, thanks for your help so far.

So now it happened again with a new presentation, but this time it worked on some displays but not all. The one I activated auditing on worked just fine of course, but other displays presented with the same error as previously.

This is from one of the displays that downloaded the new file but did not update the schedule.xml:

Does that tell you anything?