Schedule not possible in Xibo 1.8.5


i have updated from 1.8.2. to 1.8.5 and created different layouts.
Then i wanted to schedule this layouts.
But every time when i add a schedule it is not visible in the calendar view and also does not work.
Any idea how to fix this?

Do you have display to which you’re scheduling those events selected on the Schedule page?

Is it docker or manual/custom installation?

Does it show any error? Have you tried to go through the Report Fault Wizard?

Yes, a display is selected.
If i open a layout and say schedule now i can see it running on that display.

It’s a custom installation with xampp.

I don’t see any error. After adding the event to schedule in get a success message.

This is what i get from the Fault Wizard:

Large File Uploads
Support for uploading large files is recommended.We suggest setting your PHP post_max_size and upload_max_filesize to at least 128M, and also increasing your max_execution_time to at least 120 seconds.
ZeroMQ is used to send messages to XMR which allows push communications with player

That’s not quite what I mean, but since you’re there, you may want to ensure that PHP settings and environment configuration (including XMR and XTR) are correctly set.

You can also check what date format you have in CMS settings -> Regional tab
and the timezone set there.

Could you show me the screenshots of Schedule page and edit event form please?
I presume this is on-premise installation to which I won’t be able to connect over internet?

I already fixed the PHP settings.
Not sure for now how to handle the other configuration but i think it is not part of my main problem.

Here are some screenshots.


On Schedule page, near the ‘Add Event’ you do not have any display selected, so that might be why you don’t see the events you’ve created - unless of course you did check that before already.

Settings looks fine, I’d expect to see the event on Schedule page once you select the display there.

I selected the specific display before as well as “All”.

Still no events showing up.

On Agenda view for the display there is nothing as well?
It’s definitely not just browser cache issue?

You could also enable CMS auditing and see if what’s logged when you add a new event.

You could also connect to your database and run
SELECT eventId, campaignId, fromdt, todt from schedule;
to see if those events are in the database and are just not displayed in the web ui for some reason.

Looks like this was kind of the solution for my problem.

I found about 30 entries in the database. Just deleted them all and created a new event.
This was showing up and also working as expected.
Maybe something was wrong with the updateing process?

Thanks for helping me.

At a guess either something went very wrong during upgrade, or one/some of the events were created with odd dates or using dayparts that no longer exists perhaps (there were couple of problems with those).

In any case I’m glad that clearing the schedule table solved the problem for you.