Running the cms web with custom ports

I installed and configured the xibo cms with docker and when I want to run it on custom port, as the documentation says, I copied the file ‘cms_custom-ports.yml.template’ to the ‘cms_custom-ports.yml’ file and change the ports section for cms-web part from ‘65501:80’ to ‘8080:80’ to be run the cms web on port 8080. But no response is received from the port 8080.
What can I do?

How are you then starting docker?

docker-compose -f cms_custom.ports.yml up -d`

If so, can you paste the output of docker-compose ps so that we can see what containers are running?

Thanks a lot. :slight_smile: Problem is solved.

1 Like

Hi Dan, All,

I’m facing the same problem with custom ports. Please have a look at my command output, below & let me know if you have any idea why my browser times out on http://192.168.1.130:8123 I want xibo to listen on port 8123

Thanks!

Bil

Here’s the command output:

docker-compose -f cms_custom-ports.yml up -d
Starting xibodocker1810_cms-db_1
Starting xibodocker1810_cms-xmr_1
Recreating xibodocker1810_cms-web_1

docker-compose -f cms_custom-ports.yml start
Starting cms-db … done
Starting cms-xmr … done
Starting cms-web … done

netstat output:

tcp6 0 0 :::8123 :::* LISTEN 20924/docker-proxy

I flushed iptables: sudo iptable -F

cms-web:
image: xibosignage/xibo-cms:release-1.8.10
volumes:
- “./shared/cms/custom:/var/www/cms/custom”
- “./shared/backup:/var/www/backup”
- “./shared/cms/web/theme/custom:/var/www/cms/web/theme/custom”
- “./shared/cms/library:/var/www/cms/library”
- “./shared/cms/web/userscripts:/var/www/cms/web/userscripts”
restart: always
links:
- cms-db:mysql
- cms-xmr:50001
environment:
- XMR_HOST=cms-xmr
env_file: config.env
ports:
- “8123:80”
mem_limit: 1g

Flushing iptables will break Docker networking completely.

You need to restart the Docker service to allow it to put its rules back in place, and then up the containers again.

Thanks Alex.

Did not know Docker made entries into iptables. I cleaned up iptables then restarted the docker service & container. After that, it worked as expected.

Bil