Problem with Xibo player - index out of range

Hello,
I test the xibo player (1.8R5) on ubuntu 18.04 and the configuration is OK.
The screen is activate in xibo console but on the terminal of the player i have this error.
does anyone have a solution ?
{argument index out of range}

For information i have 0.7 for XMR and 1.8.13 for CMS

Hi,
I have the same problem.
Did you solve your problem?
Do you have a solution?

Reproduced on:
Ubuntu 18.04.4 LTS
xibo-player 1.8-R5 50 latest/stable
xibo-player 1.8-R5 104 latest/beta
xibo-player 1.8-R5 106 latest/edge

Hi,
No i don’t solve my problem

Hi,
i got the same message on a fresh install, ubuntu 18.04 with xibo-player 1.8-R5 laster stable and xibo-player 1.8-R6 108 latest/candidate.
I resolve the problem with a Reconfigure the XMR for this player.

Thanks for that input - does the solve the issue for the two previous posters? If yes, please let me know and I’ll create a bug report for it.

hi,
this problem was resolve for me
thanks

1 Like

I got the same error with linux player on clean and updated install of lubuntu and xibo-player 1.8-R6 108 latest/candidate. xibo cms 2.3.8.

Can you post details or screenshot of how you reconfigured the XMR for this player to resolve?

Hi, you just need to go in the player configuration on the xibo web interface :
Player =>Action (on the right) and Edits => Advanced =>Tick the box " Reconfigure XMR"
Restart the player

Hi, sry for my delay i didn’t see your answer.
What do you mean by “does the solve the issue for the two previsou posters?”
Thanks

Found it under xibo admin web interface: Display => Edits => Advanced =>Tick the box " Reconfigure XMR"

Client: restart the xibo player

Still errors “{argument index out of range}” on the linux player and does not download or play any content.
Windows players connected to same xibo server play content ok.

Any other location of logs we can check either from the linux xibo player or xibo server to help troubleshoot the error?

Do linux xibo players need to be configured differently on the xibo server Display Settings?

Also have installed the linux xibo player via snap. Does the latest XMR version 0.8 for the linux client also need to be installed separately? if so whats the command line to install.

Maybe you could delete the content folder in your xibo client and restart it.
There is some month there were a problem with linux profil and we need to custom it, i don’t know if it’s repair now but you can custom your linux profil in your cms (Players profils => Linux => Edits=> Localisation=> and spécifie your width and height)

Tried that and it does change the screen res on the Linux Client player, but Same contiously looping error. Never downloads anything.

Here is the debut error when I launch from terminal:

signage@ICSvm:~$ xibo-player
[15:04:08.153] [8166] [error]: [DBus] ScreenSaver wont’be suspended: org.freedesktop.DBus.Error.ServiceUnknown

(player:8166): Gtk-WARNING **: 15:04:08.194: Theme parsing error: gtk.css:1566:23: ‘font-feature-settings’ is not a valid property name

(player:8166): Gtk-WARNING **: 15:04:08.201: Theme parsing error: gtk.css:3616:25: ‘font-feature-settings’ is not a valid property name

(player:8166): Gtk-WARNING **: 15:04:08.203: Theme parsing error: gtk.css:4078:23: ‘font-feature-settings’ is not a valid property name
[15:04:08.304] [8166] [debug]: [CollectionInterval] Interval updated to 60 seconds
[15:04:08.793] [8178] [debug]: [CollectionInterval] Started

** (player:8166): WARNING **: 15:04:08.821: AT-SPI: Could not obtain desktop path or name

** (player:8166): WARNING **: 15:04:08.824: *tk-bridge: GetRegisteredEvents returned message with unknown signature

** (player:8166): WARNING **: 15:04:08.825: atk-bridge: get_device_events_reply: unknown signature

** (player:8166): WARNING **: 15:04:08.826: atk-bridge: get_device_events_reply: unknown signature
[15:04:09.042] [8178] [debug]: [XMDS::RegisterDisplay] Success
[15:04:09.493] [8178] [debug]: [XMDS::Schedule] Received
[15:04:09.493] [8178] [debug]: [XMDS::RequiredFiles] Received
*[ LOG ERROR #0001 **] [2021-01-16 :04:09] ogger] {argument index out of range}
[15:04:09.883] [8178] [debug]: [XMDS::MediaInventory] Submitted
[15:04:10.129] [8178] [debug]: [XMDS::SubmitLogs] Submitted
[15:04:10.129] [8178] [debug]: [CollectionInterval] Finished. Next collection will start in 60 seconds
[15:05:10.130] [8233] [debug]: [CollectionInterval] Started
[15:05:10.414] [8233] [debug]: [XMDS::RegisterDisplay] Success
[15:05:10.855] [8233] [debug]: [XMDS::Schedule] Received
[15:05:10.856] [8233] [debug]: [XMDS::RequiredFiles] Received
[
LOG ERROR #0047 *] [2021-01-16 15:05:10] [logger] {argument index out of range}

Hi all,

I hope this helps… I was experiencing this issue a couple of days ago, the exact same ‘argument index out of range’ error in the terminal (CMS 2.3.8, Ubuntu 20.10, Snap player 1.8-R6). The player was in touch with the CMS and knew which files it needed, it just wouldn’t download anything.

Eventually figured it out… I’m using Apache for reverse proxy on my CMS server, and the issue started when I put an HTTPS redirect into my port 80 virtual host config. Removing the redirect has solved this problem. If you have a similar config, perhaps give this a go. I’m guessing that changing your XMR public address in your CMS settings from your DNS address to your IP address would possibly also fix this… but that’s just a guess! I will be trying this and switching the redirect back on at some point next week.

1 Like

Possible… We are using reverse proxy with https. Whats the path of the file you remove the https redirect on port 80?

Also the public xmr address is currently blank. should the xmr be tcp://192.168.x.x:9505 ?

Checked Our Reverse proxy settings. It does NOT have a redirect.
Any more ideas?
This would have to be a Linux Player issue?
As it works on Windows Player
ReverseProxyXibo

I have the redirect, but it did not fix anything when I dropped it, it just meant that I have to key in https myself…

Could you try to remove SSL certificates lines in xibo-cms.conf file. maybe that will work…

If the ssl certificates is removed… that would break the secure https.

Could this problem cause very slow connections to the server? Its taking me up to 45 minutes now to send even small files down to the clients

try newest install from channel=edge, for me the player then seem to work.
will have to remove player and new install channel edge