Problem with New windows client registration after xibo 1.8.6 to 2.0.0 rc1 upgrade

Hi all,

I previously had a working custom install of Xibo 1.8.6 with 1 registered win7 display.
I had been waiting on the V2 public release so I could upgrade to my new PHP7 server build on WAMP. With the new version released I sideways copied my existing 1.8.6 server folder to the new server, and overstamped it with the V2 release files, then transferred the mySQL tables with the data migration utility of the mysql editor. In preparation, I also had to get zmq loading in php which is now running (never had that working in v1.8.6).
I then hit trouble when trying to load and config the new release.
After much googling and community support, I found out the migrate option that had to be run from DOS. This completed cleanly. I then found I could sign into the Xibo front end.

My next task was to then build a new Win10 windows player client. I got a PC built and installed the client, but can not get it to register as no matter what I do, i get the following client response;
There has been an unknown error with XMDS, it has been logged. Please contact your administrator…

Googling this, I saw a couple of posts about how the web server must publish the /web as a document root folder, so have made the changes with the alias statement in apache config, and can now access the web folder directly from {server}/xibo, which seems to work well, and I can still access the cms front end on the server. The URL rewrite also appears to work as I dont have to specify index.php

But my fault with the windows 10 player issues still stands.
I see no log detail in the cms logs relating to any connection attempt, and google searching that phrase only leads me back to the issue about how /web must be document root (which it now is), and also another thread about display name must be the same in both default-config.xml and config.xml, which I have manually altered in default-config.xml to match the config.xml displayname.

I am now stuck.

Would appreciate any pointers as to what else this may be.

FYI, I found in another thread that communication to XMDS is done via a URL command. I disabled firewall thinking that may be impacting, if it was using some additional ports, but this made no difference. I can query the XMDS.php and I do receive a response.
If I try http://{server}/xibo/xmds.php I receive the following back;

<?xml version="1.0" encoding=" ISO-8859-1"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http">
            <faultstring>Bad Request</faultstring>

You shouldn’t be editing xml files on the Player.

All you need to do is install it, open the Player Settings application and enter the CMS URL and key. The URL will be the same you use to access the login page - eg http://server/xibo and the key will be the one in your CMS Settings.

You should be able to enter that same URL in to the browser on that PC and see the CMS login page. If you can’t, you need to fix that before trying to configure the Player. As you say, it would most likely be a firewall or other access control, but because it’s a custom install it’s very hard for us to guide you as we don’t know what you’ve got setup or how.

Thanks Alex,

I can open the URL in IE and I do get the CMS login page on the win10 client PC.
The player options are;
CMS address http://{my server ip}/xibo/ (tried with and without tail / )
Key as taken from CMS>Settings>CMS Secret Key
Library as pre-filled by client software (c:\users{username}\Documents\Xibo Library)

I only changed the default-config.xml file to match the display name, as that is what I found in one of the other forum threads as a possible solution, but it made no difference;

Admittedly different version, and my display name was


rather than just <DisplayName />

I have disabled firewall for now so it doesnt interfere.


And what does the Player say when you save your changes in the Player settings app?

Just what I mentioned before. When I click Save, you get a quick “Saving With CMS… Please Wait…”, then a second later, the message mentioned previously;
The request failed with the error message:

There has been an unknown error with XMDS, it has been logged. Please contact your administrator.

Not sure what log it is referring to, but I dont see anything on the actual CMS under Logs 8\


Under advanced, I have no proxy settings set, as expected as I am on the local Lan. It has a random Display ID string which must be application generated I guess.
Clicking Display admin button takes me to the CMS login screen with IE.
Clicking Launch Client simply loads the Xibo splash screen, and it stays like that forever.
I can not see any log files generated under the “program files (x86)>xibo player” directory.
Interestingly, I have a xiboclient.xml file directly under %appdata% which seems to contain my config details. This is what is being read when I load the Xibo Player Options application.
It contains my server key, serverUri, and librarypath, all being set correctly.

Have just noticed something and not sure whether this is correct procedure.
On my c:\apache24\htdocs I have a xibo-cms folder. Inside this is the web folder which is served as document root for an alias as /xibo.
However I noticed that there was also a physical folder structure called xibo, which is not something I created. I have removed that folder, but when I sign in to the cms front end, this folder gets re-created.
Should this folder be the alias redirected to the xibo-cms/web folder?? It has a library folder within it, and under that, a cache/screenshots/temp folders, and further in, random generated folder and .php files.
Have I a mismatched config somewhere maybe?

I can find the library location under cms>settings>configuration>library Location which does infact point to this folder structure of c:\apache24\htdocs\xibo\library, however I can not change it to c:\apache24\htdocs\xibo-cms\library\ as when I press save, I get a red notification box stating “Unexpected Error, Please contact Support”


Further thinking about this issue, I originally copied over my 186 build which was in a folder xibo, and then i copied the 200 files over the top and upgraded. It was only after this, that the issues with the /web document root folder became apparant, so I fixed this with an alias and I moved my xibo folder structure to xibo-cms, and aliased a xibo.
I have inverted this scenario now, so that my original folder structure is still xibo, and the alias is now the xibo-cms. I have tested the cms front end, and that still works the same, however I am still unable to modify the library path in the settings (but should not need to now, as it now points to the correct physical file space), but the windows 10 player still refuses to work with same error as before.

Just going to BUMP this one.
Also I can not make any changes to settings in the CMS front end (troubleshooting/settings for example), as I wanted to put into test mode instead of production to get some more logging, but just get the message “unexpected error, please contact support”


OK, as had no further input on this issue, i figured I would rebuild my setup.
So I started again and went with the method of new build instead of upgrade.
This presented itself with a whole new set of issues.

When on configuration page for the Database setup, I discovered that whenever I tried to do a new database, it would create the Schema but fail straight afterwards with a GRANT issue;
GRANT ALL PRIVILEGES ON ‘xibo’.* to ‘xibo’@’%’ IDENTIFIED BY ‘newpassword’;
After this point the install stops.
I figured that this could be fixed with the below, but that was no use as would have to remove the schema and start the install again, and therefor hit the same problem.
ALTER USER ‘xibo’ IDENTIFIED WITH mysql_native_password BY ‘newpassword’;

So to work around this I figured I would create the Schema myself, and the account myself, and apply the alter user statement to fix it to native password. Then use the option during setup to use existing database and password.

This is where the next gotya hits you. When Selecting the Existing tab and pre-filling in the data and clicking next, it ended up looping back the the same failure messages saying couldnt grant yada yada.

It wasnt until a lot of playing around afterwards that I noticed that aswell as hitting the Existing Tab, there was a radio check box labelled Use an existing database. As I already clicked Existing Tab, this did not strike me as important as I was already in the tab to use existing and this is what I was expecting to do. The NEW tab also has a radio button, and this is selected as default. Just by selecting the EXISTING tab and filling in the details, does not mean you are using the Existing setup, infact you are still using the NEW tab setup if you click next without selecting the radio button ASWELL under the existing tab.
After knowing this, my installation went through flawlessly.

So to sum it all up,
If you are on a WAMP server with PHP 7.x, and a Mysql 8.0 install that defaults to caching_sha2_password authentication model type for new accounts, then follow these steps.

Create the Database Schema manually - no tables or content required, just the schema name.
Create a new user account (xibo for example) and when configured run the following against that username;
ALTER USER ‘xibo’@’%’ IDENTIFIED WITH mysql_native_password BY ‘newpassword’;
(you may need to alter the above to fit if you are explicit to an IP instead of all (%))
Grant that user access to just the xibo schema, and grant all privileges (Object rights/DDL rights/Other Rights).
Now run the CMS install, and when it comes to the database setup, choose the EXISTING tab, and ensure that you select the radio button Use an existing database..and populate the fields as required, then press Next. If all is well there will be a small delay whilst the tables are created.

Hope that helps someone as it really annoyed me going round in circles several times!

Probably too late, since your thread is from April, but I had the same problem after upgrading to 2.0. After the upgrade of the CMS from 1.8.x to 2.0.1, everything worked fine, and I was able to upgrade my Win 10 players to the latest v2 version. However, I had to reimage a computer and I started with v2 Player install from scratch on that computer (I didn’t upgrade from 1.8 to 2.x player on this one machine).

I got the same “There has been an unknown error with XMDS, it has been logged. Please contact your administrator” error. In the “Logs” section of the Xibo admin GUI, I had XMDS post errors under “RegisterDisplay” with message “SQLSTATE[HY000]: General error: 1364 Field ‘overrideConfig’ doesn’t have a default value” every time I tried to connect this new display player.

This appears to be due to the display table in the CMS database; since you said you re-did your entire CMS database, you already fixed it, but I was able to just enter this MySQL command
(ALTER TABLE display MODIFY overrideConfig text NULL;) and then the player would connect.

Xibo error while register display - 1364 Field 'overrideConfig' doesn't have a default value pointed me in the right direction. Somehow my display table still had the overrideConfig field set to not allow NULLs.

Hope it helps someone else who finds this thread.