Problem Order Dataset on 2 columns

Is there a way to order data in a dataset first on the first column and also on the second column?
now i sort on one column, but the data in the second column is a kind of messy.

something like below as a result?

1 a
1 a
1 b
2 a
2 b
3 b
3 d
3 f
4 a
5 b

dataset view / ticker can use SQL clause for ordering data.

so in order field you could put
column1 DESC,column2

This sorts everything by column1 (descending) first, and then by column2 (ascending, which is the default) whenever the column1 fields for two rows are equal.

this does not give the result i want. “Lesuur” isn’t ordered.

please remove the space after ,



this is the result i wanted.

Thx Peter.

Great, I’m glad it works.

As a side note, in 1.8 it will be a bit more user friendly, it looks like this:

With an optional checkbox to write your own sql syntax of course.

1 Like